email entry: improve overall accessibility

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: MarcoZ, Assigned: yzen)

Tracking

(Blocks: 1 bug, {access})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
access
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Once added, touching, then double-tapping a recipient doesn't do anything.
(Assignee)

Updated

3 years ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
Created attachment 8552230 [details] [review]
Github pull request.

This one is ready for review but depends on bug 1068712 (e.g. contains an extra commit).
Attachment #8552230 - Flags: review?(jrburke)
(Assignee)

Updated

3 years ago
Depends on: 1068712
(Assignee)

Updated

3 years ago
Blocks: 1068719
(Assignee)

Updated

3 years ago
Blocks: 1068717
(Assignee)

Comment 2

3 years ago
The issues that email entry has that are being addressed:
* better labeling of all controls
* better taget sizes
* improved accessibility of the bottom and header panels.
Summary: email entry: recipients aren't operable with the screen reader → email entry: improve overall accessibility
Comment on attachment 8552230 [details] [review]
Github pull request.

r+ for the changeset related to this bug, and providing the unit test passes on Treeherder (it seems to have died for the initial run on this pull request).
Attachment #8552230 - Flags: review?(jrburke) → review+
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla-b2g/gaia/commit/c322468a7fc9e12a59774d34147f9c1754f1bf30
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Comment on attachment 8552230 [details] [review]
Github pull request.

[Approval Request Comment] This pull request fixes accessibility for email entry screen.
[Bug caused by] (feature/regressing bug #): Improvement
[User impact] if declined: Screen reader users will not be able to use the email entry screen in Email app
[Testing completed]: Added unit tests for changes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/27548/files#diff-4
Attachment #8552230 - Flags: approval-gaia-v2.2?
Requesting on-device testing for this before uplifting .
Flags: needinfo?(yzenevich)
(Assignee)

Comment 7

3 years ago
I did all my development/testing for this bug on device, does that suffice?
Flags: needinfo?(yzenevich)

Updated

3 years ago
Attachment #8552230 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/44f8fdf7e133dfd0db2099ae9a23ca07b1c55f3f
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
You need to log in before you can comment on or make changes to this bug.