Closed Bug 1068877 Opened 5 years ago Closed 5 years ago

No ringtone from speaker when headset is connected to DUT

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: bhargavg1, Assigned: scheng)

References

Details

(Keywords: regression, Whiteboard: [caf priority: p2][CR 726401])

Steps to Reproduce:
1. Boot up the DUT
2. Select some ring tone from UI SettingsàSound àRingtones
3. Set ring tone volume to Max level from UI Settings -> Sound -> Ringtones & Notifications
4. Connect headset to DUT
5. Make an MT call
6. Observe that there is no MT call ringtone playing in speaker device.
7. Note: Ring tone is observed in headset device

Gaia - 713448b8963cd53c561f4b38640f8c63b655ce33
Gecko - 395370094caa386ebf8fe8831d030bc5484fa599
Version - v2.1
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
QA Wanted to see if we can reproduce on Flame KK 2.1
Keywords: qawanted
Verified that this bug occurs on the Flame 2.1 KK.

When a device calls the DuT with a headset in, the ringtone is heard in the headset and NOT in the device speaker.

Repro: 5/5

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20140917073957
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: d7ad9b5167d8
Version: 34.0a2
Firmware Version: L1TC00011650
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Because we can successfully repro this on the Flame device - QA-Wanted for a full branch check.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
This bug repro's on Flame KK builds: Flame 2.2, Flame 2.1, OpenC 2.2

Actual Results: Ringtones play through headset when one is plugged in but NOT through the device speaker during an incoming call.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master KK
BuildID: 20140916155959
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 543f57ab6a44
Version: 35.0a1 (Master) 
Firmware Version: L1TC00011650
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20140917073957
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: d7ad9b5167d8
Version: 34.0a2
Firmware Version: L1TC00011650
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Open_C 2.2 Master
BuildID: 20140916170759
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK, Flame 1.4 Base KK

Actual Result: Ringtones play through both speaker and headset.

Repro Rate: 0/3 attempts

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20140917073857
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: e02fe140c0d5
Version: 32.0 (2.0) 
Firmware Version: L1TC00011650
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Device: Flame 1.4
BuildID: 20140814202332
Gaia: 129211661489feb60bbd6772a44081d23b374f17
Gecko: 
Version: 30.0 (1.4)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
Component: Gaia::Ringtones → AudioChannel
I think it would be best to evaluate if playing through both the headphone and the speaker is the desired behaviour here. There might be a case where the user only wants the ringtone to play through the headphones. 

Ni? on Carrie who is the owner of the dialer UX. Carrie can you clarify what the expected behaviour is and if this bug is valid?
Flags: needinfo?(cawang)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage+]
Whiteboard: [CR 726401]
Whiteboard: [CR 726401] → [caf priority: p2][CR 726401]
QA Contact: jmercado
On the latest master build, this issue does not occur as written.  Now when the user has headphones plugged into the phone and receives a call, the audio comes out of both the device and the headphones.  However, the audio from the device in this situation is much less loud than it would be without the headphones plugged in.  Per comment 6 this might be the intended results.  Removing the regression window tag for now, but if it's determined that this is not what is desired please add the tag again.

Environmental Variables:
Device: Flame 2.2
BuildID: 20140919111450
Gaia: 12d634c63ec8a41553a9f150c38260c992dc0020
Gecko: a084c4cfd8a1
Version: 35.0a1 (2.2) 
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
blocking-b2g: 2.1? → 2.1+
I think we dealt with this issue before (can't find the bug at the moment), the audio should be played out through both headset and speaker and if we are gonna adopt this rule, the volume should be consistent as it's without the headset plugged in. Otherwise, users might get confused on the volume changes here. Thanks!
Flags: needinfo?(cawang)
as my test on v2.2 (Flame), ringtone works on speaker and headset. However, speaker behaves low volume (indicator is max volume). does this correct behavior?
Hi, 

per comment 7 and also my reply in comment 8, the current behavior is incorrect (played through both speaker and headset but the speaker volume is lower than expectation). 
My suggestion is 

1. the audio should be played out through both headset and speaker
2. the volume should be consistent as it's without the headset plugged in

Thanks!
Eric, can you please help with an assignee here?
Flags: needinfo?(echou)
Star will help.
Assignee: nobody → scheng
Flags: needinfo?(echou)
I can't duplicate the STR of comment 0 withe latest SW [1] on Flmae device. 

[1](kk-flame)


Hi, bhargavg1

Can you duplicate it with the latest SW?
Flags: needinfo?(bhargavg1)
Any update from CAF?
Flags: needinfo?(bhargavg1) → needinfo?(poojas)
(In reply to Star Cheng [:scheng] from comment #13)
> I can't duplicate the STR of comment 0 withe latest SW [1] on Flmae device. 
> 
> [1](kk-flame)
> 
> 
> Hi, bhargavg1
> 
> Can you duplicate it with the latest SW?

We are also not able to reproduce this issue with latest software.

Below are the Gaia and Gecko details we tried with.
Gaia: "93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b"
Gecko: "c896bc5d04b8c08dcddd78195901503a3578a08f"
Flags: needinfo?(poojas)
Shall we mark this as resolved worksforme ?
Flags: needinfo?(bbajaj)
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(bbajaj)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.