Closed Bug 1068946 Opened 5 years ago Closed 5 years ago

Frequent B2G debug cpptest "DMError: Timeout exceeded for shell call" at the start of jsapi-tests

Categories

(Firefox OS Graveyard :: General, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RyanVM, Assigned: dminor)

Details

Attachments

(1 file)

These have been getting reported under Bug 908268 since late last week, with a big spike starting a couple days ago. Right now, the failure rate is ~50%. If not addressed, it's enough to consider hiding the suite again.

Here's a typical failing run:
https://tbpl.mozilla.org/php/getParsedLog.php?id=48305865&tree=Mozilla-Central&full=1#error0

Compare to a green run:
https://tbpl.mozilla.org/php/getParsedLog.php?id=48140885&tree=Mozilla-Central&full=1

What immediately stands out to me is:
12:33:25     INFO -  *** UTM:SVC TimerManager:registerTimer - id: user-agent-updates-timer

Retriggers on m-c are pointing to this inbound merge as when things went orange-crazy, but I don't see anything obvious in it:
https://tbpl.mozilla.org/?jobname=b2g_emulator_vm%20mozilla-central%20debug%20test%20cppunit&rev=02c3915bf742

We've had multiple issues in the past with update timers causing crazy things during tests in other B2G suites. Is it possible that we aren't properly disabling them for xpcshell?
Maybe we need something like this ported to remotecppunittests.py?
https://bugzilla.mozilla.org/attachment.cgi?id=8463826&action=diff
Summary: Frequent B2G debug xpcshell "DMError: Timeout exceeded for shell call" at the start of jsapi-tests → Frequent B2G debug cpptest "DMError: Timeout exceeded for shell call" at the start of jsapi-tests
Disabling the jsapi tests seems to stabilize things [1]. More work is needed to figure out the root cause of this problem.

[1] https://tbpl.mozilla.org/?tree=Try&rev=f825e077ce86
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Attachment #8491590 - Flags: review?(ryanvm)
Attachment #8491590 - Flags: review?(ryanvm) → review+
Keywords: leave-open
(In reply to TBPL Robot from comment #35)
> submit_timestamp: 2014-11-28T16:53:39
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=mozilla-
> central&job_id=704781
> repository: mozilla-central
> who: philringnalda[at]gmail[dot]com
> machine: tst-linux64-spot-329
> buildname: b2g_emulator_vm mozilla-central opt test cppunit
> revision: e90536aa55dd
> 
> DMError: Timeout exceeded for shell call
> Return code: 1
> No tests run or test summary not found

The failure here was in test_statement_scoper not jsapi-tests. I was afraid I had missed skipping the jsapi-tests failure when I changed up the cppunit test manifest format.
(In reply to TBPL Robot from comment #37)
> submit_timestamp: 2014-12-11T00:21:50
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=mozilla-
> inbound&job_id=4543224
> repository: mozilla-inbound
> who: tomcat[at]mozilla[dot]com
> machine: tst-linux64-spot-074
> buildname: b2g_emulator_vm mozilla-inbound debug test cppunit
> revision: 99d8d92a319b
> 
> DMError: Timeout exceeded for shell call
> Return code: 1
> No tests run or test summary not found

The failure here was in test_transaction_helper not in jsapi-tests. I think we should either change the summary here or file a new bug for these failures so they're being starred correctly. I'm not sure offhand if this is the same problem that was affecting the now disabled jsapi-tests or if this is something new :/.
Flags: needinfo?(cbook)
Closing this for now. If/when someone cares enough about the jsapi-tests on the b2g emulator to notice they're no longer enabled we can follow through on identifying a root cause for this.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(cbook)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.