[Calendar] Events do not sync from pc to device.

RESOLVED DUPLICATE of bug 1072525

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1072525
3 years ago
3 years ago

People

(Reporter: WasiemH, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-flame-test-run-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8491065 [details]
logcat_20140917_1409.txt

Description:
Scheduling an event on Google calender on pc, will not sync, nor appear on the device calender.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140917000205
2) Sign into google account calendar.
3) Sync with google server.
4) Schedule an even in google calender on the PC.
5) Refresh the calender on the mobile device.
  
Actual:
Event does not appear on device.
  
Expected:
Event appears on device.
  
Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2456/
See attached: logcat, video clip: http://youtu.be/NNlKinel6GM
(Reporter)

Comment 1

3 years ago
Issue DOES occur on Flame 2.1 (512mb), Open-c 2.1


Scheduling an event on Google calender on pc, will not sync, nor appear on the device calender.

Flame 2.1 (512 mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Issue does NOT occur on: Flame 2.2 (319mb), Flame 2.0 (319mb)JB base, Flame 2.0 (319mb)KK base, Open-c 2.2, Open-c 2.0

Scheduling an event in google calendar on PC, will sync and appear on Flame device calendar. 

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame 2.2
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C 2.2
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140917003040
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 2.0

Enviromental Variables:
Device: Open_C 2.0
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This was working in 2.0 so nominating 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140805163728
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: e66e1130da31
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140805170721
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: 6cbdd4d523a7
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = Repro
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: 6cbdd4d523a7
Broken Gaia / Working Gecko = No repro
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: e66e1130da31
Gecko pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e66e1130da31&tochange=6cbdd4d523a7


Mozilla Inbound
Last working
BuildID: 20140805084148
Gaia: e93780f9da8b34f370a4113abd4df9780d58e443
Gecko: 72f85a52a2ca
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140805090754
Gaia: e93780f9da8b34f370a4113abd4df9780d58e443
Gecko: 8ecb3e5d5013
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = Repro
Gaia: e93780f9da8b34f370a4113abd4df9780d58e443
Gecko: 8ecb3e5d5013
Broken Gaia / Working Gecko = No repro
Gaia: e93780f9da8b34f370a4113abd4df9780d58e443
Gecko: 72f85a52a2ca
Gecko pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=72f85a52a2ca&tochange=8ecb3e5d5013
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
possibly broken by bug 1028582, can you take a look Eric?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(ekr)

Comment 5

3 years ago
Since this is WebRTC only and should only apply when NSS is a server,
it seems like an unlikely place to look. Can you verify please that
just backing this commit list out fixes the problem?
Flags: needinfo?(ekr)
This looks unlikely related to ekr's patch.

Dylan, given the range can someone from calendar team look at it ?
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(doliver)

Updated

3 years ago
Assignee: nobody → evanxd

Comment 7

3 years ago
The regression window(Comment 3) shows that this is a Gecko issue. So we need a Gecko developer here, not Gaia calendar team member.
Assignee: evanxd → nobody
Flags: needinfo?(doliver)

Comment 8

3 years ago
In Comment 3, it looks like some gecko module is just broken.

Eric, do you know any Gecko developer could help this?

Thanks.
Flags: needinfo?(ekr)

Comment 9

3 years ago
(In reply to Evan Tseng [:evanxd][:愛聞插低] from comment #8)
> In Comment 3, it looks like some gecko module is just broken.
> 
> Eric, do you know any Gecko developer could help this?

I'm not sure why you're asking me. Is there any reason to
believe that this defect has anything to do with me?
Flags: needinfo?(ekr)
Finally, found out the commit caused this issue.
We have this issue after we enable http2 and alpn in this[1] commit.

Hi Nicholas,
Could you take a look?
Thanks.

[1] http://hg.mozilla.org/mozilla-central/rev/72f85a52a2ca
Component: Gaia::Calendar → Networking: HTTP
Flags: needinfo?(hurley)
Product: Firefox OS → Core
the cset from comment 10 just turns on h2-14, which google gfe will now negotiate.

abr is chasing a (different?) issue around DAV and google.. at this point it isn't clear why goog is returning a 4xx response to his DAV request but he's working with a contact there to try and get it sorted out. Presumably its some kind of interop issue of the flavor we're looking to identify.

I think its possible this bug should block on that - abr to advise?
Flags: needinfo?(hurley)
If we use the previous version[1] of [2](it means that we don't enable http2 and alpn), then we could not reproduce this bug.

After Gecko has [2] commit, calendar app could not add google account, and it always shows "Server Error". So this bug might be duplicated of Bug 1067270, and it is also a gecko bug.

[1] http://hg.mozilla.org/mozilla-central/rev/ac28ef70b931
[2] http://hg.mozilla.org/mozilla-central/rev/72f85a52a2ca
the commit enabled h2-14, which google.com will negotiate. The working theory is that there is a problem in the google backend in their h2-14 support (something is triggering the backend to generate a 4xx response). abr is working with them to diagnose the use case I mentioned in comment 11 and the appropriate side with the err will fix it.

Comment 14

3 years ago
(In reply to Patrick McManus [:mcmanus] from comment #11)
> the cset from comment 10 just turns on h2-14, which google gfe will now
> negotiate.
> 
> abr is chasing a (different?) issue around DAV and google.. at this point it
> isn't clear why goog is returning a 4xx response to his DAV request but he's
> working with a contact there to try and get it sorted out. Presumably its
> some kind of interop issue of the flavor we're looking to identify.
> 
> I think its possible this bug should block on that - abr to advise?

It certainly sounds like the same kind of problem we're having in Bug 1072525, and I would be surprised if it weren't the same issue. I'll update that bug with some notes about what we know so far, update it to reflect the larger problem, and make this bug depend on it.

Updated

3 years ago
Depends on: 1072525
Hi Adam,

It sounds like this bug will be fixed once Bug 1072525 is fixed.
Nice!
per comment 15
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072525
You need to log in before you can comment on or make changes to this bug.