Closed Bug 1068997 Opened 6 years ago Closed 6 years ago

Implement keyboard shortcut for composition's "Find and Replace" on MAC

Categories

(SeaMonkey :: MailNews: Composition, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.32

People

(Reporter: michaelaccountsly, Assigned: stefanh)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29
Build ID: 20140904221224

Steps to reproduce:

Hit command-F (Mac user) in an email under composition to pull up Find/Search-and-REPLACE Email Text tool


Actual results:

Only got a "find" option similar to that in the browser -- no "replace" option.


Expected results:

I should have been given a field in which to give text to replace the searched-for text, as with all prior Seamonkey versions.
Looks like the functions have been separated.

Ctrl+F, Find.
Ctrl+H, Find & Replace.

(Don't ask me, I can only tell you what I see.)

> Searching within a message compose window will now display the find toolbar.
http://www.seamonkey-project.org/releases/seamonkey2.29/
(In reply to therube from comment #1)
> Looks like the functions have been separated.
> 
> Ctrl+F, Find.
> Ctrl+H, Find & Replace.
> 
> (Don't ask me, I can only tell you what I see.)

Are you on Windows? On my Mac, control-h gives backspace, command-h gives 'hide,' and option-h gives what looks like a small apostrophe.
CC stefanh as he has a Mac
Looks like there is no Mac shortcut for opening the Find & Replace dialog. We could implement one, but I'm unsure what to use.
(In reply to Stefan [:stefanh] from comment #4)
> Looks like there is no Mac shortcut for opening the Find & Replace dialog.

"No shortcut": is there any way at all to call it up? I don't see anything in the dropdown menus.


> We could implement one, but I'm unsure what to use.

I for one use find-and-replace rather often, so I'd certainly appreciate *some* way to do it, and a shortcut would be preferable. As to what to use: well, having control-h give backspace is totally redundant, and I have no idea what that little blip is that you get with option-h; is either of these a suitable sacrificial victim? Or what about  option-r or control-r or shift with one or the other?
(In reply to Michael from comment #5)

> is there any way at all to call it up? I don't see anything
> in the dropdown menus.

Edit --> "Find and Replace..." when in messenger compose window.
(In reply to Stefan [:stefanh] from comment #6)


> Edit --> "Find and Replace..." when in messenger compose window.

Huh -- don't know how I missed that -- thanks.

Reinstatement of a keyboard shortcut WOULD be nice, though ...
Michael, in Seamonkey on MAC, you should still be able to use Alt+E,L (or whatever the mac equivalent of access keys is). In Thunderbird, there's also a keyboard accessible Replace button on the Find toolbar, so Ctrl+F, then Alt+L does the trick, and if your muscle memory tricked you into Ctrl+F, the button is handy to get into the Replace dialogue. You could file a bug for porting the replace button to SeaMonkey, shouldn't be too hard (see Bug 530629).
Summary: Find/Search-and-REPLACE Email Text Gone → Implement keyboard shortcut for composition's "Find and Replace" on MAC
There are no accesskeys on Mac. We should implement a new shortcut that optionally matches the one that other mac apps has. I'm currently leaning on Cmd+Alt+F (which is what textedit and xCode have), but I need to think about it a bit more.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is there any good reason not to just revert to command-F? this is what it used to be, and it worked fine as regular "find" as well as for "find-and-replace."
Well, Cmd+F is used everywhere else to bring up the find bar.
This implements Cmd+Alt+F for Mac. I updated the help files as well. Karsten, if you're not available, just dismiss the request and I'll try to find someone else.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #8492764 - Flags: review?(mnyromyr)
Version: SeaMonkey 2.29 Branch → Trunk
Thank you for this — though I'm not yet clear what you did :) . Is this code that is now going to be incorporated into the next release? Or is it somehow to be used by individual users to enable this function in their current browsers? If the latter, how would a *real* rube like me make use of it?

Again, thank you for taking the time (and using your expertise) to work on this!
(In reply to Michael from comment #13)
> Thank you for this — though I'm not yet clear what you did :) . Is this code
> that is now going to be incorporated into the next release?

Yes :-) The code needs review first, though. Once I got an r+ (review granted) this change will be incorporated in the development code which will then be uplifted to Aurora (alpha code) when the next uplift occur and then 6 weeks later be uplifted to beta. After 6 weeks again, the code will be in the release.
Attachment #8492764 - Flags: review?(mnyromyr) → review+
http://hg.mozilla.org/comm-central/rev/959757d9032c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.32
Stefan, while you're at it, could you port this nice little patch to Thunderbird, too?
Flags: needinfo?(stefanh)
It's a bit different since Thunderbird doesn't use overlays, so it's not a straight port. But you could file a bug and we'll see what we can do.
Flags: needinfo?(stefanh)
You need to log in before you can comment on or make changes to this bug.