Closed Bug 1069047 Opened 5 years ago Closed 5 years ago

WebRTC encoder statistics reports incorrect dropped frames for H.264

Categories

(Core :: WebRTC: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
blocking-b2g 2.1+
Tracking Status
firefox36 --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: jaywang, Assigned: jesup)

References

Details

(Whiteboard: [caf priority: p2][CR 694553])

Attachments

(1 file)

It appears that SPS/PPS are counts as part of key frame and causes incorrect dropped frame count from the following equation:
uint32_t dropped = mSentRawFrames - (keyFrames + deltaFrames);Please, refer to [1] for the complete source.

This causes the dropped count become negative.

[1]http://git.mozilla.org/?p=releases/gecko.git;a=blob;f=media/webrtc/signaling/src/media-conduit/CodecStatistics.cpp;h=39b7fd87ed11f1965e044708c2a9b9e370b5ae3d;hb=HEAD#l54
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Whiteboard: [CR 694553]
Whiteboard: [CR 694553] → [caf priority: p2][CR 694553]
:mreavy, can you help comment on this one ? Do any blockers that we've fixed, to support H.264 may have caused this?
Flags: needinfo?(mreavy)
This bug goes back to the beginning basically.  I've asked jesup to take a quick look at this to see if there's an easy fix.
Flags: needinfo?(mreavy)
CAF p2 = blocking+
blocking-b2g: 2.1? → 2.1+
NI :jesup for feedback on comment #3 and if we will be able to have a low risk fix here in the next week or so for 2.1
Flags: needinfo?(rjesup)
Randell believes he may have a low risk solution for this.
Assignee: nobody → rjesup
Jesup, is having a patch here and is currently testing it out before landing..
Attachment #8505032 - Flags: review?(pkerr)
Attachment #8505032 - Flags: review?(pkerr) → review+
Comment on attachment 8505032 [details] [diff] [review]
Only count one frame (key vs delta) in stats per timestamp

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A

User impact if declined: Incorrect/unusable statistics for dropped frames and keyframes vs delta frames.

Testing completed: Manually tested on desktop/Openh264

Risk to taking this patch (and alternatives if risky): Virtually no risk; just turns off bumping the stats values if the timestamp didn't change.

String or UUID changes made by this patch: none
Attachment #8505032 - Flags: approval-mozilla-b2g34?
https://hg.mozilla.org/mozilla-central/rev/556ad64e03e2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Attachment #8505032 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18b785142556

Do we need this on the Fx release branches as well?
Flags: needinfo?(rjesup)
Flags: needinfo?(rjesup)
You need to log in before you can comment on or make changes to this bug.