Mover handling is borked on move.pl.

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
P3
minor
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: CodeMachine, Assigned: justdave)

Tracking

2.15
Bugzilla 2.18

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
When I enter the following for movers:

a@b.com, c@d.com

The code detects c@d.com is a mover on bug_form.pl, but not move.pl.  This is
because:

my $movers = Param("movers");
$movers =~ s/\w?,\w?/|/g;
$movers =~ s/@/\@/g;

Those \w should be \s.

There should also be a routine that does this for both sides in globals.pl.

For both, that should probably be (\s)* too, not (\s)?.
(Reporter)

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
Created attachment 112318 [details] [diff] [review]
Patch v1

Fixes both move.pl and Bug.pm so either format of lists of movers works
Comment on attachment 112318 [details] [diff] [review]
Patch v1

This is already applied on both mothra and bugscape (had to because someone
needed to move a bug).	Seems to work so far, but I'd appreciate a sanitycheck.
Attachment #112318 - Flags: review?(myk)
Created attachment 112322 [details] [diff] [review]
Patch v2

Take 2: move.pl defines user.login for show.xml.tmpl now.  Moving actually
works now. :)
Attachment #112318 - Attachment is obsolete: true
Attachment #112318 - Flags: review?(myk)
Attachment #112322 - Flags: review?(myk)
Comment on attachment 112322 [details] [diff] [review]
Patch v2

This does solve the problem, and for me it also made fixed bug_form.pl to show
the "move" button.
Attachment #112322 - Flags: review?(myk) → review+
Checking in Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.28; previous revision: 1.27
done
Checking in move.pl;
/cvsroot/mozilla/webtools/bugzilla/move.pl,v  <--  move.pl
new revision: 1.17; previous revision: 1.16
done
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 256135 has been marked as a duplicate of this bug. ***
Assignee: myk → justdave
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.