Closed Bug 1069182 Opened 5 years ago Closed 5 years ago

Unable to exit out of Guest Browsing via system notification

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox35 --- verified
fennec 35+ ---

People

(Reporter: u421692, Assigned: wesj)

References

Details

(Keywords: reproducible)

Attachments

(2 files)

Attached file logs
Environment:
Device: Samsung Galaxy Nexus(Android 4.2.1)
Build: Nightly 35.0a1 (2014-09-17)

Steps to reproduce:
1. Open Menu->Tools->New Guest Session
2. From Android notification bar, tap on Guest browsing android notification

Expected result:
Guest session is closed

Actual result:
Tapping on Guest browsing android notification does not exit guest session
(see attached logs)
tracking-fennec: --- → ?
Keywords: reproducible
Summary: Tapping on Guest browsing android notification does not exit guest session → Unable to exit out of Guest Browsing via system notification
Assignee: nobody → wjohnston
tracking-fennec: ? → 35+
Attached patch PatchSplinter Review
Err. I must have moved this code at some point. If Gecko was running our onNewIntent code would never be hit because !Intent.ACTION_MAIN.equals(action) is always true. I also made this an implicit intent to avoid confusion between different releases.
Attachment #8491901 - Flags: review?(bnicholson)
Comment on attachment 8491901 [details] [diff] [review]
Patch

Review of attachment 8491901 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/BrowserApp.java
@@ +2935,5 @@
>          if (!mInitialized) {
>              return;
>          }
>  
>          // Only solicit feedback when the app has been launched from the icon shortcut.

Nit: Move comment back down to keep it with the ACTION_MAIN return.
Attachment #8491901 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/dad1d0099623
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Verified as fixed in
Build: Firefox for Android 35.0a1 (2014-09-25)
Devices: 
Asus Transformer Pad TF300T (Android 4.2.1)
Nexus 4 (Android 4.4.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.