Closed Bug 1069353 Opened 6 years ago Closed 5 years ago

Unlock "button" does not work with screen reader when PIN is configured

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

(Keywords: access, Whiteboard: [b2ga11y p=1])

Attachments

(2 files)

The button does not do anything via screen reader when there is an unlock PIN.
Assignee: nobody → eitan
There seems to be a similar issue with pickup/hangoup when someone calls. This is a much more critical use case, since it makes the phone unusable as a phone.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Hi Eitan, thanks for helping this out. The 2.2 FC is April 6th, just checking if this can be fixed before then ? Cheers.
Flags: needinfo?(eitan)
Flags: needinfo?(eitan)
Attachment #8580109 - Flags: review?(alive)
Comment on attachment 8580109 [details] [review]
[gaia] eeejay:bug-1069353 > mozilla-b2g:master

Deliver review to Greg.
Attachment #8580109 - Flags: review?(alive) → review?(gweng)
Comment on attachment 8580109 [details] [review]
[gaia] eeejay:bug-1069353 > mozilla-b2g:master

I think the code is good but unfortunately there is no test for lockscreen_slide.js, so to land this would violate the rule of System app that every patch would need a corresponding unit test, that other peers had once set my r+ to r- without any discussions. So I think you should create it first (under sharedapptest app directory) and add the tests in the file. Or if you already have related integration test you could add the test, too.

If you have any problem to add this test you could NI me again. Sorry for the inconvenience.
Attachment #8580109 - Flags: review?(gweng)
Comment on attachment 8580109 [details] [review]
[gaia] eeejay:bug-1069353 > mozilla-b2g:master

Updated with a unit test. It was easier to do than I thought!
Attachment #8580109 - Flags: review?(gweng)
Comment on attachment 8580109 [details] [review]
[gaia] eeejay:bug-1069353 > mozilla-b2g:master

OK with test the patch is fine. Thanks a lot.
Attachment #8580109 - Flags: review?(gweng) → review+
https://github.com/mozilla-b2g/gaia/commit/36b6f9f824782457ae0674382604cb69d915dee4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8580109 [details] [review]
[gaia] eeejay:bug-1069353 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Screen reader users can't unlock the screen when PIN is configured. Neither could they answer a call from the lock screen.
[Testing completed]: Yes. And unit test added.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: No.
Attachment #8580109 - Flags: approval-gaia-v2.2?
Attachment #8580109 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as pass on latest Nightly build of Flame v2.2&3.0 by the STR in Comment 0 & Comment 9.

Actual results: Screen reader users can unlock the screen when PIN is configured, and they also can answer a call from the lock screen.
See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/6


Device: Flame v2.2 build(Pass)
Build ID               20150604002503
Gaia Revision          b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gaia Date              2015-06-04 05:59:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/273f8ee45c88
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150604.102004
Firmware Date          Thu Jun  4 10:20:13 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0 build(Pass)
Build ID               20150604160205
Gaia Revision          e0fbadeb78a96137f071d9be7a47ef9fe882d17f
Gaia Date              2015-06-04 07:44:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5b4c240e1a36
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150604.192904
Firmware Date          Thu Jun  4 19:29:16 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.