Concise methods should not have a prototype

RESOLVED DUPLICATE of bug 1059908

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1059908
4 years ago
3 years ago

People

(Reporter: Erik Arvidsson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The following test should pass but it doesn't.

var o = {
  m() {}
};
console.assert(!('prototype' in o.m))

https://people.mozilla.org/~jorendorff/es6-draft.html#sec-method-definitions-runtime-semantics-propertydefinitionevaluation
dup of bug 1059908

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059908

Updated

3 years ago
See Also: → bug 1166950
You need to log in before you can comment on or make changes to this bug.