All users were logged out of Bugzilla on October 13th, 2018

1px vertical lines appear on <tab>'s

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: simmo, Assigned: eric)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

383 bytes, application/vnd.mozilla.xul+xml
Details
1.88 KB, image/png
Details
(Reporter)

Description

17 years ago
1px vertical lines appear at random near the right edge of <tab/>'s when they
start to get bunched.

A small screenshot will be attached.
(Reporter)

Comment 1

17 years ago
Created attachment 55238 [details]
screenshot of lines in tabs

Comment 2

17 years ago
I see this, too. 2001102609 linux

It has to be a rounding issue: Get as many tabs open as you need to cover the
whole tabbar. Then open the sidebar and resize it slowly. See the vertical bars
appear on a regular basis.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 3

17 years ago
Created attachment 55382 [details]
Testcase

Comment 4

17 years ago
Comment on attachment 55382 [details]
Testcase

Incorrect mimetype
Attachment #55382 - Attachment mime type: text/xul → application/vnd.mozilla.xul+xml

Comment 5

17 years ago
-> xul

Testcase-howto: The testcase is a simplified 'tabbar' (really: 3 vboxes with
flex=1). Open sidebar and resize the sidebar slowly. The white line appears
whenever the inner width is divisibly by 3 :

inner width = vbox1 + vbox2 + vbox3
   973 px   =   324 +   324 +   324  +1 white bar
   974 px   =   325 +   324 +   325
   975 px   =   325 +   325 +   325
   976 px   =   325 +   325 +   325  +1 white bar
Component: Tabbed Browser → XP Toolkit/Widgets: XUL
Keywords: mozilla1.0

Comment 6

17 years ago
-> box man!
Assignee: hyatt → evaughan
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0.1 → ---

Comment 7

17 years ago
*** Bug 109716 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

17 years ago
*** Bug 111221 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 111671 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 111884 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 117431 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
This bug doesn't exist anymore in Build ID 2001122603 (Win98) and probably in
later ones neither (at least I never got a line so far). The lines were also
flickering when the window was resized, even if they didn't get displayed once
you stopped resizing. This is gone, too.

Just annoying that this fix didn't make it to release 0.97 anymore.

Comment 13

17 years ago
true, the gaps are now between the tabs (2001122803)

Comment 14

17 years ago
*** Bug 133542 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Created attachment 79464 [details]
Testcase

Here's a (working) testcase.   I can't reproduce the bug anymore though; can
anyone else? Maybe we can mark this WORKSFORME.
Attachment #55382 - Attachment is obsolete: true

Updated

17 years ago
Attachment #79464 - Attachment mime type: text/plain → application/vnd.mozilla.xul+xml

Comment 16

17 years ago
Created attachment 79467 [details]
Screenshot of new testcase

The lines aren't in the tabs any more (as I said in comment 13), but see for
yourself: The bug still exists.
Attachment #55238 - Attachment is obsolete: true

Comment 17

15 years ago
worksforme moz 1.4. can anyone reproduce the problem?

Comment 18

15 years ago
Problem still appears - 2003081204/trunk/W2K
(Reporter)

Comment 19

14 years ago
Marking as WORKSFORME
No longer appears, old bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.