Closed Bug 1069508 Opened 7 years ago Closed 7 years ago

deal with tracebacks from unknown locales in Balrog

Categories

(Release Engineering Graveyard :: Applications: Balrog (backend), defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1069454

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

We hit a bunch of these after shipping to the Beta channel: https://errormill.mozilla.org/Releng/balrog-prod/group/172432/

There's two main causes:
1) People putting random things as a locale, eg: "en-USmr"
2) Locales that we shipped at one time, but don't anymore. Eg: "mn".

KeyError: u'mn'

Stacktrace (most recent call last):

  File "flask/app.py", line 1060, in full_dispatch_request
    rv = self.dispatch_request()
  File "flask/app.py", line 1047, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File "flask/views.py", line 56, in view
    return self.dispatch_request(*args, **kwargs)
  File "flask/views.py", line 112, in dispatch_request
    return meth(*args, **kwargs)
  File "auslib/web/views/client.py", line 38, in get
    xml = release.createXML(query, update_type, app.config["WHITELISTED_DOMAINS"], app.config["SPECIAL_FORCE_HOSTS"])
  File "auslib/blob.py", line 222, in createXML
    localeData = self.getPlatformData(buildTarget)["locales"][locale]
I expect to deal with this as part of bug 1069454.
Assignee: nobody → bhearsum
This is definitely getting addressed in bug 1069454.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1069454
Product: Release Engineering → Release Engineering Graveyard
You need to log in before you can comment on or make changes to this bug.