Make sure shuffle is a toggle button.

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: yzen, Assigned: eeejay)

Tracking

({access})

unspecified
2.2 S7 (6mar)
All
Gonk (Firefox OS)
access

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Shuffle button should have toggle button semantics so the screen reader user knows what state it is on.
Created attachment 8562366 [details] [review]
[PullReq] eeejay:bug-1069624 to mozilla-b2g:master
(Assignee)

Updated

4 years ago
Attachment #8562366 - Flags: review?(dkuo)
(Assignee)

Updated

4 years ago
Assignee: nobody → eitan

Comment 2

4 years ago
Comment on attachment 8562366 [details] [review]
[PullReq] eeejay:bug-1069624 to mozilla-b2g:master

Looks good to me and apologize for keeping you waiting!
Attachment #8562366 - Flags: review?(dkuo) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Created attachment 8578792 [details] [review]
[gaia] eeejay:bug-1069624_v2.2 > mozilla-b2g:v2.2
(Assignee)

Comment 5

4 years ago
Comment on attachment 8578792 [details] [review]
[gaia] eeejay:bug-1069624_v2.2 > mozilla-b2g:v2.2

Rebased on v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Toggle mode of shuffle button will not be known to screen reader users
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: No.
Attachment #8578792 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8578792 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/4fea751c70ecee7121ff2e6f0bae00d2ef694cf0
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.