[FTE][Firefox Accounts] Dragging cursor results in loss of caret and functionality

RESOLVED DUPLICATE of bug 1054570

Status

RESOLVED DUPLICATE of bug 1054570
4 years ago
4 years ago

People

(Reporter: rpribble, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8491892 [details]
Logcat.txt

Description:
If the user tries to drag the cursor using the caret while typing in the email entry text field, the caret and cursor will disappear. The user will be unable to edit their entry and they will have close the widow and restart to do so.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140917223000
2) Progress through the FTU to the Firefox Accounts page
3) Type an account in to the email entry field
4) Long press on the email address and try to drag the caret

Actual:
The caret disappears after dragging it and user has to close the window and restart if they need to edit their entry.
  
Expected: 
No loss of functionality.
  
Environmental Variables:
Device: Flame 2.2 Master (319 MB)
BuildID: 20140917223000
Gaia: d37950eb09e28aa18d0e01df9ff90574bd4337e0
Gecko: 426497473505
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Notes:
  
Repro frequency: 100%
See attached: Video, logcat
(Reporter)

Comment 1

4 years ago
Adding qawanted for branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.1-Daily-Testing]
This bug repro's on Flame KK builds: Flame 2.2, Flame 2.1, Flame 2.0, Flame 2.0 Base

Actual Results: Able to lose the cursor on the firefox account page by dragging the Carat (Utility Bubble). Occurs on both FTU and the Settings FFA.

Repro Rate: 4/4

Environmental Variables:
Device: Flame Master KK
BuildID: 20140919052449
Gaia: d170091ba1b5597b05f37fb259f6b8eb02568798
Gecko: 3475e6a1665a
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Device: Open_C 2.2
BuildID: 20140919052449
Gaia: d170091ba1b5597b05f37fb259f6b8eb02568798
Gecko: 3475e6a1665a
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1, Flame 2.0, Flame 2.0 Base

Actual Result: Unable to get the cursor get get disabled during FFA because there is no carat (utility bubble) to grab and drag.

Repro Rate: 0/10

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20140919050548
Gaia: f0f22bb46c881e02524b3991c2587ff8c0a9fc37
Gecko: ab2a88c05a4b
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20140919041249
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: fb1589259e4f
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Device: Flame 2.0 KK Base
BuildID: 20140904160718
Gaia: 506da297098326c671523707caae6eaba7e718da
Gecko: 
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
Sorry, this only repro's on Flame 2.2 KK and OpenC 2.2 because they are the only builds with carats (Utility bubble) to drag and lose the cursor.
Not a regression but a broken new-feature as the carat did not exist prior to 2.2

Nomming for 2.2 as it breaks functionality of the carat
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
Component: Gaia::First Time Experience → Gaia::System::Input Mgmt
changing flags - 'unaffected' assumes that the bug COULD be reproduced there but does not, but this is 2.2 functionality only.
status-b2g-v2.0: unaffected → ---
status-b2g-v2.1: unaffected → ---
This should be the same issue as Bug 1054570 with the same reason as bug 1068567 comment 8,
===
with the following line in CSS, the password and email field of Firefox account page could not be selected or changed the cursor position with caret handler,
https://github.com/mozilla-b2g/gaia/blob/76c4c0ac9f59f9cbe963c7cceea9201f2fbbade2/apps/system/fxa/style/fxa.css#L14
===
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Gaia::System::Input Mgmt → FxA
Resolution: --- → DUPLICATE
Duplicate of bug: 1054570
Remove the nomination here, because bug 1054570 has been v2.0+'ed.
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.