Firefox can't find the file at resource://gre/modules/commonjs/sdk/ui/frame/view.html

RESOLVED FIXED in mozilla35

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: xabolcs, Assigned: froydnj)

Tracking

({regression})

unspecified
mozilla35
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(firefox34 unaffected, firefox35- affected)

Details

Attachments

(3 attachments)

Reporter

Description

5 years ago
STR:
0. get a Nightly between 2014-09-11 and now (2014-09-18)
For example:
> Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140918030202 CSet: 426497473505

1. install a ui/toolbar enabled addon (for example the attached, development version of memchaser)
2. notice the almost hidden retry button in the memchaser toolbar
3. disable preference browser.xul.error_pages.enabled
4. restart addon with disabling and enabling it
5. Firefox presents an ultra-wide alert box complaining about missing files.

For example:
> Firefox can't find the file at resource://gre/modules/commonjs/sdk/ui/frame/view.html#PGlmcmFtZSB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMTk5OS94aHRtbCIgaWQ9ImZyYW1lLW1lbWNoYXNlcnF1YWxpdHktbW96aWxsYS1vcmctcmVzb3VyY2UtLW1lbWNoYXNlci1hdC1xdWFsaXR5LWRvdC1tb3ppbGxhLWRvdC1vcmctbWVtY2hhc2VyLWRhdGEtZ3Vpb2JqZWN0LWd1aW9iamVjdC1odG1sIiBzcmM9InJlc291cmNlOi8vbWVtY2hhc2VyLWF0LXF1YWxpdHktZG90LW1vemlsbGEtZG90LW9yZy9tZW1jaGFzZXIvZGF0YS9ndWlvYmplY3QvZ3Vpb2JqZWN0Lmh0bWwiIHNlYW1sZXNzPSJzZWFtbGVzcyIgc2FuZGJveD0iYWxsb3ctc2NyaXB0cyIgc2Nyb2xsaW5nPSJubyIgZGF0YS1pcy1zZGstaW5uZXItZnJhbWU9InRydWUiIHN0eWxlPSJib3JkZXI6bm9uZTtwb3NpdGlvbjphYnNvbHV0ZTt3aWR0aDoxMDAlO3RvcDogMDtsZWZ0OiAwO292ZXJmbG93OiBoaWRkZW4iLz4=.


Actual results:
Addon doesn't get it's ui/frame content.


Expected results:
Addon works, the content is displayed.


mozregression:
No more inbounds to bisect
Last good revision: d2be6598ca2b
First bad revision: 1a6883cb1a09
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d2be6598ca2b&tochange=1a6883cb1a09
Contains one Bug: Bug 1056324
This looks strange because nothing in that original bug points out that the patch has been landed. Maybe it was by accident. I have asked Nathan on the other bug. Lets cc him here too.
Blocks: 1056324
Keywords: regression
[Tracking Requested - why for this release]:
A possible accidentally pushed patch causes some add-ons to misbehave because necessary SDK resources cannot be found.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 3

5 years ago
Looks like some changes were made in bug 1037235 that I must not have merged
properly when I committed the patch for bug 1056324.  Let's fix that up first.
Attachment #8492159 - Flags: review?(evold)
Assignee

Comment 4

5 years ago
This bit actually fixes the bug; we need to include html files (of which
view.html is the only one) in the JS modules install as well.  Given:

[froydnj@cerebro gecko-dev.git]$ find addon-sdk/source/lib -type f |egrep -v '(js|jsm|html)$'
addon-sdk/source/lib/sdk/system/child_process/LICENSE
addon-sdk/source/lib/sdk/system/child_process/README.md
addon-sdk/source/lib/diffpatcher/Readme.md
addon-sdk/source/lib/diffpatcher/History.md
addon-sdk/source/lib/diffpatcher/License.md
addon-sdk/source/lib/diffpatcher/.travis.yml
addon-sdk/source/lib/diffpatcher/package.json
addon-sdk/source/lib/method/Readme.md
addon-sdk/source/lib/method/History.md
addon-sdk/source/lib/method/License.md
addon-sdk/source/lib/method/.travis.yml
addon-sdk/source/lib/method/package.json

I don't think anything else needs to be added, unless you would like the
various readme/license files included for completeness.
Attachment #8492161 - Flags: review?(evold)
Assignee

Updated

5 years ago
Assignee: nobody → nfroyd
Attachment #8492159 - Flags: review?(evold) → review+
Attachment #8492161 - Flags: review?(evold) → review+
https://hg.mozilla.org/mozilla-central/rev/432cdf1c88a9
https://hg.mozilla.org/mozilla-central/rev/a6e93c843089
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.