Closed Bug 1069691 Opened 6 years ago Closed 6 years ago

[GonkIntegration] Unable to run b2g-info due to NUWA being detected as second B2G process

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: bzumwalt, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-2])

Description:
When user attempts to run the b2g-info script the output indicates that b2g-info is unable to run due to two B2G processes running at the same time.

flash@FlashStation77:~$ adb shell b2g-info
Fatal error: Two B2G main processes found (pids 290 and 553)

Further investigation reveals that NUWA is being detected as a B2G process.

flash@FlashStation77:~$ adb shell b2g-ps
APPLICATION      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      290   1     210752 65688 ffffffff b6f2763c S /system/b2g/b2g
(Nuwa)           root      553   290   53652  9408  ffffffff b6f2763c S /system/b2g/b2g
Homescreen       u0_a947   947   553   76192  26832 ffffffff b6f2763c S /system/b2g/b2g
Find My Device   u0_a1291  1291  553   62044  19280 ffffffff b6f2763c S /system/b2g/b2g
(Preallocated a  u0_a2054  2054  553   59484  16936 ffffffff b6f2763c S /system/b2g/b2g

Repro Steps:
1) Update a Flame device to BuildID: 20140917160201
2) Plug device in and enable Adb debugging
3) Enter "adb shell b2g-info" into terminal
  
Actual:
User is unable to run b2g-info due to two b2g processes being detected.
  
Expected: 
User can run b2g-info without incident.

Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140917160201
Gaia: 379e68fe729a684fa2fcddb30ea1e65508db73e1
Gecko: 7cb113c3ce0c
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12922/
See attached: logcat
Issue DOES occur on Flame 2.2 (319mb), OpenC 2.2, Flame 2.1 (512mb), Flame 2.1 KitKat Base (319mb), and OpenC 2.1

Flame 2.2 (319mb)
Device: Flame 2.2
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2
Device: Open_C 2.2
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 (512 mb)
Device: Flame 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.1 KitKat Base (319mb)
Device: Flame 2.1
BuildID: 20140917123004
Gaia: ad374f4b2a07cb5711679322a815f9feadb5cf64
Gecko: b4d5f9314661
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1
Device: Open_C 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Actual Results: User is unable to run b2g-info due to two b2g processes being detected.


Issue does NOT occur on Flame 2.0 (319mb), Flame 2.0 KitKat Base (319mb), OpenC 2.0, Flame 1.4 (319mb), OpenC 1.4

Flame 2.0 (319mb)
Device: Flame 2.0
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 KitKat Base (319mb)
Device: Flame 2.0
BuildID: 20140917003040
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0
Device: Open_C 2.0
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4 (319mb)
Device: Flame 1.4
BuildID: 20140916183018
Gaia: efa2b8cb095407df942fee7732a5547c7034ef9b
Gecko: 07ab32a08e18
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4
Device: Open_C 1.4
BuildID: 20140916183018
Gaia: efa2b8cb095407df942fee7732a5547c7034ef9b
Gecko: 07ab32a08e18
Version: 30.0 (1.4)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual Results: User can run b2g-info without incident.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
I thought it should be fixed already but haven't patched by rel eng.  ni? ting-yu for more detail information.
Flags: needinfo?(tchou)
This duplicates bug 1048024. Please make sure gonk-misc is updated, a rebuild/reflash to update /system/bin/b2g-info should fix it.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(tchou)
Resolution: --- → DUPLICATE
Duplicate of bug: 1048024
Sorry, it was actually fixed in bug 1050026.
Duplicate of bug: 1050026
Paul told me it seems related to how is PVT build created, and probably there're some build scripts need to be fixed, reopened.
Status: RESOLVED → REOPENED
Depends on: 1050026
Resolution: DUPLICATE → ---
When we flash only gaia and gecko, we don't actually update some gonk utilities, such like b2g-ps or b2g-info.
Since we don't perform full flash, not sure if we have general way to push them.

Tony, what is recommended in this situation, or do you know who own this task?
Flags: needinfo?(tchung)
(In reply to Paul Yang [: pyang] from comment #6)
> When we flash only gaia and gecko, we don't actually update some gonk
> utilities, such like b2g-ps or b2g-info.
> Since we don't perform full flash, not sure if we have general way to push
> them.
> 
> Tony, what is recommended in this situation, or do you know who own this
> task?

We need to move toward full flash soon.  I was waiting on some of the KK bugs to get fixed, (ie. https://bugzilla.mozilla.org/show_bug.cgi?id=1043813), and it looks like it landed yesterday.  That said, Brogan, please full flash and see if you can reproduce this bug.   if not, close as worksforme.   Thanks.
Flags: needinfo?(tchung) → needinfo?(bzumwalt)
When I run "adb shell b2g-info" after full flash I am only partially able to run the script. The following output appears:

$ adb shell b2g-info
This program needs to run as the root user in order to query pids.

This is followed by System Memory info and LMK parameters.

When I attempt to correct the problem by running adb as root, I recieve this output:

$ adb root
adbd cannot run as root in production builds

This was done using Flame KK build 20140923003005
Flags: needinfo?(bzumwalt)
[Blocking Requested - why for this release]:

Test blocker for performance & a regression.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(In reply to Brogan Zumwalt [:BroganZ] from comment #8)
> When I run "adb shell b2g-info" after full flash I am only partially able to
> run the script. The following output appears:
> 
> $ adb shell b2g-info
> This program needs to run as the root user in order to query pids.
> 
> This is followed by System Memory info and LMK parameters.
> 
> When I attempt to correct the problem by running adb as root, I recieve this
> output:
> 
> $ adb root
> adbd cannot run as root in production builds
> 
> This was done using Flame KK build 20140923003005

production builds (when full flashing) don't have root access, so this is invalid and known.  you'll want to try a flame-kk-eng build and retry this again.
Status: REOPENED → RESOLVED
blocking-b2g: 2.1? → -
Closed: 6 years ago6 years ago
Resolution: --- → WONTFIX
I heard that this haven't been applied to recent build (pvt). This is blocking PVT v2.1 from getting logs to partner.
Blocks: MTBF-B2G
You need to log in before you can comment on or make changes to this bug.