[User Story] Expanding an App Group

VERIFIED FIXED in 2.2 S1 (5dec)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: pdol, Unassigned)

Tracking

({feature})

unspecified
2.2 S1 (5dec)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-master verified)

Details

(Whiteboard: [ucid: ][ft:systemsfe])

User Story

As a user I want to be able to expand a group that is collapsed so that I can access the apps contained within.

Acceptance Criteria:
1. By using the method described by the UX spec, a given collapsed app group is expanded resulting in the expanded state described by the UX spec.
2. Interaction and visuals match UX spec.

Attachments

(1 attachment)

Reporter

Description

5 years ago
+++ This bug was initially created as a clone of Bug #1069701 +++
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
feature-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.2 S1 (5dec)
Issue verified fixed on Flame 3.0

When expanding a collapsed group of any size from homescreen, the arrow icon rotates to up position while the group expands, revealing app titles growing to default size and any apps hidden when group was collapsed. While expanding the top position remains vertically fixed, snapping into the expanded position. The background overlay for the group grows along with the group. Apps icons retain their former positions and are not re-arranged. This behavior works the same when in edit mode on homescreen.

Device: Flame 3.0 Master
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Adding verifyme for 2.2 verification.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: verifyme
Posted video Verify_video.mp4
The problem is verified not happen on latest Flame 2.2 build.

Steps:
1. Flash latest Flame 2.2 build.
2. Navigation to Homescreen.
3. Tap arrow icon.

Actual Result:
3.User can expand or collapsed a group to access the apps contained within.

Fail rate:0/10
See attachment:Verify_video.MP4

Flame 2.2 version:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.