Closed Bug 1069817 Opened 8 years ago Closed 8 years ago

[sms] localization missing for unknown contacts

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set
normal

Tracking

(b2g-v2.1 verified, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S6 (10oct)
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- fixed

People

(Reporter: ankit93040, Assigned: steveck, NeedInfo)

References

Details

(Whiteboard: [g+][LibGLA,TD93705,QE1, B] )

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

go to sms->new sms->To Field

Type an unknown number


Actual results:

unknown contact seen in english irrespective of language


Expected results:

unknown contact should be localized
Whiteboard: [g+][LibGLA,TD93705,QE1, B]
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Keywords: late-l10n
Summary: [sms]Late-l10n for unkonow contacts → [sms] localization missing for unknown contacts
Comms triage: too late for Late-l10n changes...
blocking-b2g: 2.1? → ---
Attached file Pull Request
Please merge to master. Thanks
Attachment #8492907 - Flags: review?(schung)
Assignee: nobody → ankit93040
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: late-l10n
Ankit, have you tried this on a phone? Because I'd assume it breaks the view for known existing contacts.
Also, localization comment is partial and completely unrelated to the string.

Having said that, it's definitely a bug but it can probably be fixed without a new string and using the existing unknown-contact (which seems currently unused), so it might be 2.1 material.
We have a "unknown-contact" string but it doesn't have the right value :( 

Not sure what's the good path forward: is it better to have a weird text, or an english text?
The key was 'unknown-contact', so it's clear that "Unknown" was referring to a contact. 

We can keep "Unknown" on 2.1 and fix it properly on master with a new string, it's definitely better than showing an English string.
Comment on attachment 8492907 [details] [review]
Pull Request

Hi Ankit, since flod though using "Unknown" should be enough for 2.1, please left the localization as it is and reuse it for unknown contacts per comment 6 if you want to uplift to previous version.

Hi julien, sorry I 'm not sure about the 'weird text' you mentioned here, could you give an example for it? or maybe we could simply set content empty?
Attachment #8492907 - Flags: review?(schung)
Flags: needinfo?(felash)
I meant that showing the string "Unknown" at that moment would be strange. Also I don't know what's the state of the translations and if they still can be changed at that time, because they probably were used without much context in that case. Since we don't ship the phone in any english-speaking country as far as I know, so our paying customers would only get translations, and maybe we can still get translations right?

About keeping the content empty, I think this is a good option. Then we'd have only the phone number and an empty line above. What do you think Jenny, is it good enough for v2.1? In v2.2 we'd have the proper translated string.
Flags: needinfo?(felash) → needinfo?(jelee)
Hmmm I am ok with showing only number, but can we make the number would be at half of the line height? Otherwise it'd look unbalanced. Thanks!
Flags: needinfo?(jelee)
Assignee: ankit93040 → nobody
Steve, can we land ankit's patch on master and do another patch for v2.1?
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Steve, can we land ankit's patch on master and do another patch for v2.1?

Ok, but the original patch got a conflict here. Will solved it and re-commit patch later.
Attached file Link to github
Hi Oleg, this patch is for master. I'll create another patch for 2.1 which only reuse the existing string.
Attachment #8500217 - Flags: review?(azasypkin)
Flags: needinfo?(schung)
It's the 2.1 patch that reuse the existing "unknown" string like comment 6 said. Although I proposed removing string before, inventing another layout at this moment seems not safe even the changes might be trivial. So I choose the method with minimal changes here.
Attachment #8500220 - Flags: review?(felash)
Comment on attachment 8500217 [details] [review]
Link to github

Looks good to me, thanks!
Attachment #8500217 - Flags: review?(azasypkin) → review+
Comment on attachment 8500220 [details] [review]
Link to github(for 2.1)

Redirect to Oleg since Julien is on PTO.
Attachment #8500220 - Flags: review?(felash) → review?(azasypkin)
Comment on attachment 8500220 [details] [review]
Link to github(for 2.1)

r=me, thanks!
Attachment #8500220 - Flags: review?(azasypkin) → review+
In master: e6c0dfd544380a07b7281379eb23e0731ac5fb16
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Comment on attachment 8500220 [details] [review]
Link to github(for 2.1)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 959018
[User impact] if declined: 'unknown contact' string will not translate
[Testing completed]: N/A
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8500220 - Flags: approval-gaia-v2.1?
Comment on attachment 8500220 [details] [review]
Link to github(for 2.1)

Approving the low risk work around to improve the localization experience.
Attachment #8500220 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This issue has been verified successfully on Flame 2.1. But verified to fail on Flame 2.2.
See attachment: 1659.MP4 and logcat_1659.txt
Flame 2.1 Reproducing rate: 0/5
Flame 2.2 Reproducing rate: 5/5

Step:
1.Launch Message.
2.Create a new message, input the phone number in receiver box.
3.Switch the system language to other(ex:Japanese, Korean, Simplified Chinese, isiZulu...).
4.Then back to edit message page.

Actual result:
Flame 2.1: The "Unknown" will be localized.
Flame 2.2: When you switch the language to Korean/isiZulu or other, the "Unknown Contact" can not be localized.

Flame 2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.034824
FW-Date         Tue Dec  2 03:48:34 EST 2014
Bootloader      L1TC00011880

Flame 2.2 version:
Gaia-Rev        725685831f5336cf007e36d9a812aad689604695
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2c9781c3e9b5
Build-ID        20141202040207
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.072347
FW-Date         Tue Dec  2 07:23:58 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
Attached video 1659.MP4
Hey Steve, can you check this?

It's likely because the l10n files are not uptodate for v2.2 yet but better be sure :)

FTR http://hg.mozilla.org/gaia-l10n/ is the place where authoritative locales are located.
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #24)
> Hey Steve, can you check this?
> 
> It's likely because the l10n files are not uptodate for v2.2 yet but better
> be sure :)
> 
> FTR http://hg.mozilla.org/gaia-l10n/ is the place where authoritative
> locales are located.

Yes, it's clearly that some language's l10n files are not sync with latest changes.
In this video, we can see the language in Japanese is correct but not translated in Korean, and the latest ko l10n file changes are browser deletion on 10/14, and this patch's l10n changes is still not applied yet.
Flags: needinfo?(schung)
http://transvision.mozfr.org/string/?entity=apps/sms/sms.properties:unknown-contact-title&repo=gaia

Don't test localization on master unless you know what you're checking. Usually French or Italian and good locales to pick for that ;-)
You need to log in before you can comment on or make changes to this bug.