[Loop] Wrong attentions screens and impossible hang-up the loop call

VERIFIED FIXED

Status

Firefox OS
Gaia::Loop
--
blocker
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mbarone, Assigned: jaoo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][blocking][tef-triage][patch available], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Device: Flame
Build: v2.0 with kk v180 (gecko-2d2ca12 gaia-7edd3b0)
Loop version: c28eaef

STR
1. Create a contact using a valid email as Loop ID. 
2. Log-in into Loop
3. From Contact App perform a loop call to the contact created on step 1(make sure this email ID is not logged into loop)

ACTUAL RESULT
The app shows call end window, then the calling window and finally the unavailable window. Besides is not possible to hang-up the unavailable window
(Reporter)

Comment 1

3 years ago
I forgot. I've the following permission for Loop app
Mic: Deny
Camara:Deny
Mobile ID: ask
Contact: Grant
(Reporter)

Comment 2

3 years ago
Uploaded the video
Jose Antonio, as we talked I am assigning to you the bug. Following the same STR and with the same permissions set in Comment 1 I am able to reproduce it. you can see it in this video:

https://www.youtube.com/watch?v=upU80VGl0_s

If I set Mic and Camera permissions to granted, the flow is the correct one, as it's explained in the US bug 1007681, I am notified that the other user can’t be reached with message "Unavailable" and Call failed tone and after that sharing a callback URL screen is shown.
Assignee: nobody → josea.olivera
Whiteboard: [mobile app][blocking] → [mobile app][blocking][tef-triage]
(Assignee)

Comment 4

3 years ago
Created attachment 8492179 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/127
According what we have talked, if the GUM permissions are denied it does not make sense trying to establish the call, so prompting the user about the GUM permission issue is enough.
Jose Antonio, Borja, I've just realized that similar issue was reported in bug 1054037, so perhaps we can handle it in a unique bug. Wdyt?
Flags: needinfo?(josea.olivera)
Flags: needinfo?(borja.bugzilla)
(Assignee)

Comment 7

3 years ago
(In reply to Maria Angeles Oteo (:oteo) from comment #6)
> Jose Antonio, Borja, I've just realized that similar issue was reported in
> bug 1054037, so perhaps we can handle it in a unique bug. Wdyt?

Bug 1054037 is quite similar so let's resolve it as a DUP of this one. Thanks!
Flags: needinfo?(josea.olivera)
Flags: needinfo?(borja.bugzilla)
(Assignee)

Updated

3 years ago
Attachment #8492179 - Flags: review?(borja.bugzilla)
Whiteboard: [mobile app][blocking][tef-triage] → [mobile app][blocking][tef-triage][patch available]
Comment on attachment 8492179 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/127

Small comment to address and we are done! Great job!
Attachment #8492179 - Flags: review?(borja.bugzilla) → review+
(Assignee)

Comment 9

3 years ago
(In reply to Borja Salguero [:borjasalguero] from comment #8)
> Comment on attachment 8492179 [details] [review]
> Pointer to Github PR
> https://github.com/mozilla-b2g/firefoxos-loop-client/pull/127
> 
> Small comment to address and we are done! Great job!

Thanks, landed at:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/14f15fbeff9c3a61fcedd8c55a970c991566ee55
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1054037
Duplicate of this bug: 1045595
(Reporter)

Comment 12

3 years ago
Tested with Flame (v2.0 kk v180)
Gecko-9362b48.Gaia-6449cc3
Loop version 041ff17
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.