Closed Bug 1069867 Opened 5 years ago Closed 5 years ago

[Contacts] ICE section appears on top of the selection list right after a contact is set

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- fixed

People

(Reporter: echang, Assigned: crdlc)

Details

Attachments

(1 file)

### STR
1. Set a contact as ICE
2. ICE section appears on top of the selection list 
3. Set another ICE
4. ICE section not appears on top of the selection list 

### Actual
http://youtu.be/M1ERTn2IGcQ

### Version
Gaia-Rev        2a612867039a7cfb3af6e692bfae4482b06705e9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/004bc0d262e5
Build ID        20140918194610
Version         34.0a2
Device Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
QA Whiteboard: [COM=Gaia::Contacts]
I repro'd it. This is only visible when you select a contact at the top of the list or when the list is smaller than the screen.
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][ICE]
Assignee: nobody → crdlc
Target Milestone: --- → 2.1 S5 (26sep)
Attached file Github pull request
I would like to know your opinion about this patch before working on tests
Attachment #8495139 - Flags: feedback?(jmcf)
Attachment #8495139 - Flags: feedback?(jmcf) → feedback+
Comment on attachment 8495139 [details]
Github pull request

Comments addressed and added an unit test. Thanks for your time reviewing this patch
Attachment #8495139 - Flags: review?(jmcf)
Comment on attachment 8495139 [details]
Github pull request

excellent work. please land once TBPL is green
Attachment #8495139 - Flags: review?(jmcf) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/fad99f579f179bf25be2a20c1ff3c0a688d472d4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8495139 [details]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: not expected behavior once users select an ICE contact in the list but not high impact thought. See video to understand the problem properly
[Testing completed]: manual/unit tests
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: No
Attachment #8495139 - Flags: approval-gaia-v2.1?
Comment on attachment 8495139 [details]
Github pull request

Not bad enough to justify uplift at this point.
Attachment #8495139 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1-
You need to log in before you can comment on or make changes to this bug.