Figure out which tools are still using filesize declarations in product details

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sylvestre, Assigned: sylvestre)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
Next step after bug #1070002

Product details has plenty of hardcoded filesize information. Most of them are set to 0 and nobody cares about them (at least for fennec and firefox, thunderbird relman are still updating them).

So, the idea is to figure out which tools are expecting filesize to be set to remove them from the json file.
(Assignee)

Comment 1

4 years ago
Paul, Josh, your input would be greatly appreciated!
Flags: needinfo?(pmac)
Flags: needinfo?(jmize)
I've confirmed that at least django-mozilla-product-details (https://github.com/mozilla/django-product-details/) has no reliance on the filesize info. That's the primary tool used in webdev of which I'm aware.
Flags: needinfo?(pmac)
I'm not aware of any tools that use the filesize field in the product details json file either.
Flags: needinfo?(jmize)
(Assignee)

Updated

4 years ago
Component: Release Automation → Product Details
Product: Release Engineering → www.mozilla.org
QA Contact: bhearsum
(Assignee)

Comment 4

4 years ago
Adding Cheng & Tyler to the list of n-i.

In product details, I found this comment:
 * LATEST_FIREFOX_RELEASED_VERSION and LATEST_FIREFOX_RELEASED_DEVEL_VERSION
 * are only used by SUMO. Only update when builds are truly released.

So, it seems that you are using the product detail lib.
Flags: needinfo?(tdowner)
Flags: needinfo?(cwwmozilla)
Not sure if we use these. I'll let cheng provide details
Flags: needinfo?(tdowner)

Comment 6

4 years ago
Chatted with sumo devs, looks like they moved to django-mozilla-product-details a while back and so we don't use those fields anymore.

Thanks.
Flags: needinfo?(cwwmozilla)
(Assignee)

Comment 7

4 years ago
OK. Thanks guys. I wonder if there are other people besides bedrock and sumo using the product details.

Mark, Lawrence, Lukas, Pacsal, are you aware of other products using the json files generated by the product details?

Btw, if everybody is using django-mozilla-product-details, maybe we should move the content there. I think most of the PHP code is dead.
Flags: needinfo?(standard8)
Flags: needinfo?(pascalc)
Flags: needinfo?(lsblakk)
Flags: needinfo?(lmandel)
Dome old php pages still in production use them (I know of the channel page that we are migrating this week). Our older websites used it (mozilla.com, mozilla-europe.org, mozillamessaging.com) but we have migrated entirely mozilla-europe.org and for mozilla.com the migration to bedrock is almost complete (the Channel page is one of the last used pages, it should be migrated fully in the days to come). I think Thunderbird still probably uses product-details as there is nobody working on their pages, so AFAIK, they are not being migrated to bedrock.

We also used product-details on a variety of marketing sites (Firefox download day, flicks... /ex), basically every time we needed to have download buttons for Firefox. I have no idea if some of these sites are still in activity.

Maybe we could look at the entire svn repo and see where there are svn externals set to the product-details repo, that would be a start.
Flags: needinfo?(pascalc)
(In reply to Pascal Chevrel:pascalc from comment #8)
> Maybe we could look at the entire svn repo and see where there are svn
> externals set to the product-details repo, that would be a start.

This is a good idea. From comment 8, we can also ping marketing to see if they know. Once we've covered all of the known cases, I would be in favour of making a breaking change and seeing what breaks. We can plan to revert the change and handle the fallout after it is known.
Flags: needinfo?(lmandel)
I know at one time, there were "watchers" accessing the json files, but I suspect they wouldn't worry about the file sizes.

I thought at one time, the non-English Thunderbird download buttons used file sizes, but that doesn't seem to be the case now.

So I'm fine with dropping those.
Flags: needinfo?(standard8)
(Assignee)

Comment 11

4 years ago
Thanks Mark!

Here is the list of Mozilla's SVN project having an external declaration on the product details: 

======== addons ===========
site/vendors/product-details -r103054 https://svn.mozilla.org/libs/product-details

site/vendors/product-details -r102739 https://svn.mozilla.org/libs/product-details

trunk - site/vendors/product-details http://svn.mozilla.org/libs/product-details

======== mozillamessaging.com ===========
sites/mozillamessaging.com/branches/kinkora/includes - product-details http://svn.mozilla.org/libs/product-details

sites/mozillamessaging.com/tags/production/includes - product-details -r 90986 http://svn.mozilla.org/libs/product-details 

sites/mozillamessaging.com/tags/staging/includes - product-details -r 90986 http://svn.mozilla.org/libs/product-details 

sites/mozillamessaging.com/trunk/includes - product-details http://svn.mozilla.org/libs/product-details 

======== projects ===========
bouncer/tuxedo/trunk - inc/product-details/json https://svn.mozilla.org/libs/product-details/json

browserchoice/tags/production - product-details http://svn.mozilla.org/libs/product-details

browserchoice/trunk - product-details http://svn.mozilla.org/libs/product-details

byob/trunk - application/modules/locale_selection/vendor/product-details https://svn.mozilla.org/libs/product-details

kubla/branches/halloween - sites/all/includes/product-details http://svn.mozilla.org/libs/product-details

kubla/tags/production - sites/all/includes/product-details http://svn.mozilla.org/libs/product-details

kubla/trunk - sites/all/includes/product-details http://svn.mozilla.org/libs/product-details

mozilla-europe.org/tags/production - includes/product-details -r116763 http://svn.mozilla.org/libs/product-details

mozilla-europe.org/trunk - includes/product-details http://svn.mozilla.org/libs/product-details

mozilla.com/tags/production/includes - product-details -r132130 http://svn.mozilla.org/libs/product-details

mozilla.com/tags/stage/includes - product-details -r132130 http://svn.mozilla.org/libs/product-details

mozilla.com/trunk/includes - product-details http://svn.mozilla.org/libs/product-details

mozilla.com/trunk/tests - product-details http://svn.mozilla.org/libs/product-details

mozilla.org/branches/hagege/includes - product-details http://svn.mozilla.org/libs/product-details

mozilla.org/branches/staging/thunderbird/includes - product-details http://svn.mozilla.org/libs/product-details

mozilla.org/trunk/thunderbird/includes - product-details -r 132117  http://svn.mozilla.org/libs/product-details

mozillaonline.com/tags/production - includes/product-details -r127614 http://svn.mozilla.org/libs/product-details

mozillaonline.com/trunk - includes/product-details http://svn.mozilla.org/libs/product-details

mozparty/tags/production - app/vendors/product-details http://svn.mozilla.org/libs/product-details

mozparty/trunk - app/vendors/product-details http://svn.mozilla.org/libs/product-details

trash/moz_cleanup/trunk/trunk/includes - product-details http://svn.mozilla.org/libs/product-details


For the record, I had to checkout all the svn repo and run:
for f in $(ls -1); do cd $f && echo  "======== $f ===========" && svn propget svn:externals -R && cd -; done &> foo.log
and grep on the line containing product-details
(Assignee)

Comment 12

4 years ago
I found two usages:
1) projects/trash/moz_cleanup/trunk/trunk/js/mozilla-language-search.js
                        if (language[3][platforms[i][1]]['filesize']) {
                                anchor.title = language[3][platforms[i][1]]['filesize'] +
                                        'M ' + Mozilla.LanguageSearch.download_text;
                        }


=> trash, I don't think we should care (but it should work anyway)

2) projects/browserchoice/trunk/libs/firefox.php
        $size = Firefox::$details->primary_builds[$locale][self::$version]['Windows']['filesize'];


Not sure it is deprecated (last change: 3 years ago) but this will fail.
Flags: needinfo?(lsblakk)
(Assignee)

Comment 13

4 years ago
I reported bug 1079298 to move these projects in the trash
(Assignee)

Updated

4 years ago
Blocks: 1079304
(Assignee)

Comment 14

4 years ago
I found that I was looking for. Closing this one. Thanks all!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → sledru
(Assignee)

Comment 15

4 years ago
Actually, mozilla-language-search.js is used on the main website:
projects/mozilla.com/trunk/js/mozilla-language-search.js

but we should be fine since the code is checking that the value is present.
You need to log in before you can comment on or make changes to this bug.