trunk crash [@ nsXULDocument::ContentReplaced ]

VERIFIED DUPLICATE of bug 106646

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 106646
17 years ago
10 years ago

People

(Reporter: Jan Carpenter, Assigned: Jean-Francois Ducarroz)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
This bug is a topcrasher for the trunk.

nsXULDocument::ContentReplaced   148 crash reports
BBID range: 37167808 - 37204477
Min/Max Seconds since last crash: 7 - 58825
Min/Max Runtime: 21 - 64159
Crash data range: 2001-10-25 to 2001-10-25
Build ID range: 2001102415 to 2001102509
Keyword List : button(5), compose(17), mail(53), message(25), news(10), reply(30), 
Stack Trace: 

	 nsXULDocument::ContentReplaced
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp  line 2121]
	 nsXULElement::ReplaceChildAt
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line 2327]
	 nsXULElement::ReplaceChild
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line 1133]
	 XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp 
line 154]
	 XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp  line 1953]
	 XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp 
line 1267]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 811]
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2769]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 827]
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2769]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 827]
	 nsXPCWrappedJSClass::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp  line 1024]
	 nsXPCWrappedJS::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp  line 430]
	 PrepareAndDispatch
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp 
line 117]
	 SharedStub
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp 
line 139]
	 nsMsgCompose::NotifyStateListeners
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp  line 2927]
	 nsMsgDocumentStateListener::NotifyDocumentCreated
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp  line 2514]
	 nsEditor::NotifyDocumentListeners
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp  line 2546]
	 nsEditor::PostCreate
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp  line 363]
	 nsHTMLEditor::PostCreate
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditor.cpp  line 322]
	 nsEditorShell::PrepareDocumentForEditing
[d:\builds\seamonkey\mozilla\editor\composer\src\nsEditorShell.cpp  line 616]
	 nsEditorShell::EndPageLoad
[d:\builds\seamonkey\mozilla\editor\composer\src\nsEditorShell.cpp  line 5237]
	 nsEditorShell::OnStateChange
[d:\builds\seamonkey\mozilla\editor\composer\src\nsEditorShell.cpp  line 5010]
	 nsDocLoaderImpl::FireOnStateChange
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 1110]
	 nsDocLoaderImpl::doStopDocumentLoad
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 750]
	 nsDocLoaderImpl::DocLoaderIsEmpty
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 647]
	 nsDocLoaderImpl::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 578]
	 nsLoadGroup::RemoveRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp  line 530]
	 nsStreamIOChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp  line 482]
	 nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 177]
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591]
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
	 KERNEL32.DLL + 0x248f7 (0xbff848f7)
	 0x00688bfe
	 0x00058f64
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/content/xul/document/src/nsXULDocument.cpp
line : 2121


COMMENTS/URLs:

     (37204477)	Comments: compsing email now broken.. worked fine with nightly a few days ago
     (37204398)	Comments: clicked on an email address to compose email.
     (37202814)	Comments: compose new mail message
     (37200654)	Comments: Opened mail
     (37198880)	URL: http://linux.oreillynet.com/pub/a/linux/2001/10/05/snd_partone.html
     (37198750)	Comments: Opening email composition window
     (37198712)	Comments: Forwarding a newsgroup message
     (37198641)	Comments: Forwading a newsgroup post
     (37196181)	Comments: replying to mail with new build
     (37195409)	Comments: File->Send Page
     (37195258)	Comments: Clicked 'reply all' on the mail toolbar  crashed immediately...
     (37195223)	Comments: Clicked 'New Msg' button on the mail toolbar  crashed immediately.
     (37194128)	Comments: Tried to reply to a newsgroup post and it bombed.
     (37193265)	Comments: opened a new message
     (37193034)	Comments: Tried to open a plaintext mailnews composer window...
     (37191510)	URL: irc.mozilla.org (chatzilla)
     (37191510)	Comments: Reproducing the problem of just clicking on the compose button to
write a mail
     (37191411)	URL: irc.mozilla.org (chatzilla)
     (37191411)	Comments: Trying to send a message using the compose button
     (37191061)	URL: http://slashdot.org
     (37191061)	Comments: everytime I try to edit as new a mail  I go boom ...
     (37190807)	Comments: Creating a new mail message
     (37188629)	Comments: reply-all
     (37188484)	Comments: Attempted to reply-all on a message.
     (37188053)	Comments: oh body  that was the mai client befor I could type one letter
     (37187705)	URL: c:\\test.html
     (37187182)	URL: slashdot.org
     (37187182)	Comments: replay..    see todays topcrashers
     (37187092)	Comments: Another replay crash Grrrrrr
     (37186298)	Comments: Reply to sender blew me up... I can't reply to emails... :-(
     (37186239)	Comments: Replying to all again on a different message
     (37186187)	Comments: Replying to a message
     (37185855)	Comments: Opened message composition window
     (37184987)	Comments: In MailNews opened a message compose window
     (37184950)	Comments: clicked on a mailto: hyperlink
     (37184933)	Comments: Tried to reply to e-mail message.
     (37184931)	Comments: clicked on a mailo: link
     (37184893)	Comments: clicked on a mailto: link
     (37184143)	URL: c:\\test.html
     (37184143)	Comments: Mail compose window.
     (37184031)	Comments: Opening new mail message by clicking on MAILTO link in browser.
     (37183865)	URL: c:\\test.html
     (37183865)	Comments: Replying to a mail message
     (37183545)	URL: c:\\test.html
     (37183545)	Comments: Just replied to a mail message.
     (37183232)	Comments: sending mail. reply all
     (37183214)	Comments: i hit "reply" to answer a mail
     (37183207)	URL: c:\\test.html
     (37183207)	Comments: Crashing in mail  loading a message.
     (37183047)	Comments: reply all in mail
     (37182928)	Comments: in ng n.p.m.mail-news.  read a post and clicked Reply. crash
     (37182871)	Comments: Attempting to forward a mail message  right clicked and chose
forward.. Mozilla created the compose window and then crashed.
     (37182749)	Comments: Open new mail message by clicking on "mailto" link in the browser.
     (37182018)	URL: http://sports.espn.go.com/nba/
     (37182018)	Comments: Error occured while clicking a mailto: link
     (37181923)	URL: http://sports.espn.go.com/nba/
     (37181923)	Comments: Error occured while clicking a mailto: link
     (37181575)	Comments: Trying to send a new email.  Guess it's all broken...  Hope these
help :)
     (37181543)	Comments: Replying to an email.  
     (37179344)	URL: http://slashdot.org
     (37179344)	Comments: Starting emailcomposer crashes Mozilla
     (37178563)	URL: slashdot.org
     (37178563)	Comments: reply to message..  yeah yeah.. same bug..   
     (37178343)	Comments: Replying to mail.
     (37178101)	Comments: replying to a mail  crach on open message window
     (37178029)	Comments: replying to mail.  the composer window was mostly (maybe
completely?)drawn when the crash happened.
     (37178015)	Comments: I hit the "reply" button on an email message  and mozilla decided
to crash :)
     (37177461)	Comments: Replied to an email... original composed in Outlook... BOOM
     (37176808)	Comments: Starting to compose a new mail message
     (37176506)	URL: http://sol.dk
     (37176406)	Comments: replying to e-mail
     (37175962)	Comments: replying to an email
     (37175837)	Comments: replying to Email crashes mailnews  period.
     (37175677)	Comments: Replying to an Email (containing no attachments)
     (37175531)	Comments: forwarding a mail that had 5 attachments (Word/Excel docs)
     (37175326)	URL: slashdot.org
     (37175313)	URL: http://sol.dk
     (37175289)	Comments: replying to a message
     (37175017)	Comments: Reading mail - 3rd release or so.
     (37174522)	Comments: crash in mail compose window
     (37174006)	URL: http://www.zdnet.com/tlkbck/comment/22/0
     (37174006)	Comments: File  Send Link seems to reliably clobber Moz from this page.  the
Mail window *does* open.
     (37173967)	URL: http://www.zdnet.com/tlkbck/comment/22/0
     (37173967)	Comments: I was on this page  then did File  Send Link.  The mail window
never appeared  Moz died.
     (37173966)	Comments: crash in in mail reply
     (37173738)	URL: http://www.nandotimes.com/nation/v-text/story/156731p-1481894c.html
     (37173738)	Comments: Crash in GKCONENT.DLL when bringing up the composer to reply to a
news post
     (37173278)	Comments: in ng n.p.m.mail-news.  clicked on New Message. crash
     (37173024)	Comments: crash when bringing up message compose.
     (37172988)	Comments: crash opening compose window.
     (37172899)	URL: http://slashdot.org
     (37172899)	Comments: Crash when hitting reply to Newsgroup in MailNews
     (37172508)	URL: slashdot.org
     (37172508)	Comments: ctrl-M
     (37171718)	Comments: pressed the reply button in mail
     (37170637)	URL: slashdot.org
     (37170637)	Comments: file -> new -> message
     (37168838)	URL: http://sol.dk
     (37168838)	Comments: reply
     (37167836)	URL: http://sol.dk
     (37167836)	Comments: compose
     (37167808)	URL: http://sol.dk


(All but one crash were on Windows, 1 crash on Linux)
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 1

17 years ago
the crash is coming from compose. re setting the component.
Assignee: mscott → ducarroz
Component: Mail Back End → Composition
QA Contact: esther → sheelar

Comment 2

17 years ago
Pretty sure this is a dup of http://bugzilla.mozilla.org/show_bug.cgi?id=106646
which was fixed yesterday.

*** This bug has been marked as a duplicate of 106646 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
yes. vrfy dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsXULDocument::ContentReplaced ]
You need to log in before you can comment on or make changes to this bug.