Transform translate not applied if defined twice on SVG, once in pixels, once in percentage

RESOLVED DUPLICATE of bug 923193

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 923193
3 years ago
2 years ago

People

(Reporter: jabbrass, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2165.0 Safari/537.36

Steps to reproduce:

{
  "application": {
    "name": "Firefox",
    "version": "32.0.2",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0"
}

I'm trying to apply CSS animations to SVG paths and group elements. 


Actual results:

If you run these Codepens in the browser, hopefully they demonstrate the issue.

Broken in FF, works in Chrome: http://codepen.io/anon/pen/kJmuf
Consisent across Chrome and FF without second translate: http://codepen.io/anon/pen/rkFqd


Expected results:

I believe the expected result should be that the second transform gets applied, and the result should match Chrome's rendering.

Comment 1

3 years ago
Is the animation required at all to demonstrate this issue? I.e. Does % transform work at all? Simplifying the testcase would help in trying to diagnose the issue.
Flags: needinfo?(jabbrass)

Comment 2

2 years ago
just another transform-origin percentage example
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jabbrass)
Resolution: --- → DUPLICATE
Duplicate of bug: 923193
You need to log in before you can comment on or make changes to this bug.