Screen not dismissed when pressing 'Skip' on the PIN dialpad

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: albertopq, Assigned: mnjul)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [FT:System-Platform][p=1])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8492964 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

STR:

1.- Restart the phone with 2 SIMS (I guess it happens the same with 1) locked by PIN
2.- The PIN screen is shown
3.- Press 'Skip'

Expected:

The screen is dismissed

Actual:

The dialpad hides, but the screen remains the same, so you need to press Skip again for moving to the next screen.
(Reporter)

Comment 1

4 years ago
Adding qawanted, as I'm not sure which versions are affected
Keywords: qawanted
QA Contact: ckreinbring
The bug repros on KK Flame 2.2
Actal result: Tapping the Skip button on the SIM PIN entry screen the first time will dismiss the keyboard but not progress past the screen.

BuildID: 20140922040649
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on KK Flame 2.1
Actual result: Tapping the Skip button on the SIM PIN entry screen closes the screen.

BuildID: 20140922053548
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Platform Version: 34.0a2
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
The bug also does not repro on KK Flame 2.0
Actual result: Tapping the Skip button on the SIM PIN entry screen closes the screen.

BuildID: 20140922082143
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: dc61f92b855e
Platform Version: 32.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
status-b2g-v2.0: --- → unaffected
nomming - regression, bad UX
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: ckreinbring
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140916155959
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 543f57ab6a44
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140916162300
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 49ef7b18963d
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 49ef7b18963d
Broken Gaia / Working Gecko = Repro
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 543f57ab6a44
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e2d70bee03b5380ac327a145e5d694fb2443f018...50666fa8bbbf3d346faff24f92ad8140a44a49d0


Mozilla Inbound
Last working
BuildID: 20140915195234
Gaia: 4995f9c6a62734d2e21a1be120d69641a3c9a551
Gecko: 04176c9b3c3a
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140915204346
Gaia: 5997357e6e56da48b624ded2060fbc86f67936e1
Gecko: 7789bc797d59
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: 4995f9c6a62734d2e21a1be120d69641a3c9a551
Gecko: 7789bc797d59
Broken Gaia / Working Gecko = Repro
Gaia: 5997357e6e56da48b624ded2060fbc86f67936e1
Gecko: 04176c9b3c3a
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/4995f9c6a62734d2e21a1be120d69641a3c9a551...5997357e6e56da48b624ded2060fbc86f67936e1
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(Reporter)

Updated

4 years ago
Assignee: nobody → apastor
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(Reporter)

Comment 6

4 years ago
After bisecting this issue, it seems that is a regression from Bug 1067266.
:mnjul , any idea?
Flags: needinfo?(jlu)
Blocks: 1067266
Let me take a look. Keeping NI for reminding.
Created attachment 8494218 [details] [review]
Proposed Patch (PR @ GitHub)

The cause of this bug is that when you touchdown the skip button, the input focus from the password textbox is stolen, and then the keyboard hides, and the button repositions, which results in click event not being triggered.

I discussed with Tim and we decided not to re-introduce the blur latency in input management, since even with that old latency, we might still bump on to this bug as long as keyboard hides before the click event triggers (of course that probably would only happen on a super slow phone and/or with super long event queue, which is rather unlikely).

Instead, we'll be changing to bind skip/OK handling logics with touchend events -- note that the spec [1] says, for touchend, "...the target of this event must be the same Element on which the touch point started when it was first placed on the surface, even if the touch point has since moved outside the interactive area of the target element.", so it suits our needs.

[1] http://www.w3.org/TR/touch-events/#the-touchend-event

I don't really think we have a clearly-defined owner on this module so I'm requesting Tim's review. Please feel free to re-delegate/amend the requests if anyone thinks someone may be (also) more suitable for reviewing this.

Also, I didn't find any unit tests related to UI event handlers, so unit tests were not modified.
Attachment #8494218 - Flags: review?(timdream)
Flags: needinfo?(jlu)
Assignee: apastor → jlu
Whiteboard: [systemsfe] → [systemsfe] [p=1]
Attachment #8494218 - Flags: review?(timdream) → review+
Whiteboard: [systemsfe] [p=1] → [p=1]
Whiteboard: [p=1] → [FT:System-Platform][p=1]
(Reporter)

Updated

4 years ago
Attachment #8492964 - Attachment is obsolete: true
I've just realized that my original PR didn't trigger a TBPL run. Going to fix that now.
Master: https://github.com/mozilla-b2g/gaia/commit/5b44b5de8a1ba4361c02bd9a307f3a38389b8ad3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.2: affected → fixed
This issue is verified on Flame 2.2:

Flame 2.2 KitKat Base (319mb)(Full Flash)
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141002093155
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 5d6ec4dddf14
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The screen is dismissed correctly with both 1 and 2 sims.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.