After disconnecting from bluetooth audio (a2dp), speaker volume is very quiet

RESOLVED DUPLICATE of bug 1072021

Status

Firefox OS
Bluetooth
RESOLVED DUPLICATE of bug 1072021
4 years ago
4 years ago

People

(Reporter: cwiiis, Assigned: scheng)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [caf priority: p2][CR 729246])

(Reporter)

Description

4 years ago
Steps:

1- Play some music through the phone speaker
2- Connect to bluetooth headphones and play some music
3- Disconnect from headphones by turning off the bluetooth headphones
4- Play some music through the phone speaker

Expected:

Music plays, at the same (or similar) volume to step 1.

Actual:

All audio is very quiet, or possibly muted, and it's impossible to turn it back up again without restarting b2g.


This is a regression, this feature worked fine at some point a month or two ago, but it took me a while to realise this was happening, and to pin down exactly what was happening.

This is reasonably serious, as it seems to also affect ringer volume (but not in-call volume, as far as I can tell).

If I get the time/remember, I'll test to see if this happens in 2.1.
ni? Star to check from audio part first, this looks like not related to bluetooth, but audio volume settings.
Flags: needinfo?(scheng)
Assignee: nobody → scheng
(Assignee)

Comment 2

4 years ago
[1] After duplicating the STR

AudioPolicyManager Dump: 0xb801ceb8
 Primary Output: 2
 A2DP device address: 94:CE:2C:F3:54:83 --> [star] A2DP is connected 
 SCO device address:
 USB audio ALSA
 Output devices: 00000083               --> [star] Receiver + Speaker + A2DP 
 Input devices: 00000044
 Phone state: 0
 Force use for communications 0
 Force use for media 0
 Force use for record 0
 Force use for dock 0
 Force use for system 0


[2] Normal case
AudioPolicyManager Dump: 0xb801ceb8
 Primary Output: 2
 A2DP device address:                   --> [star] A2DP address in null
 SCO device address:
 USB audio ALSA
 Output devices: 00000003               --> [star] Receiver + Speaker 
 Input devices: 00000044
 Phone state: 0
 Force use for communications 0
 Force use for media 0
 Force use for record 0
 Force use for dock 0
 Force use for system 0


It seems not to disconnect the A2DP.
Flags: needinfo?(scheng)
QA-Wanted for a branch check first, then we'll look at adding back the regression-window
Keywords: regressionwindow-wanted → qawanted
QA Contact: ckreinbring
The bug repros on Flame 2.2 and Flame 2.1
Actual result:  After turning off the Bluetooth headset, sound cannot be played through the device when the song is resumed.  I also noticed that the timer on the song accelerated when it was resumed.

Flame 2.2
BuildID: 20140923162022
Gaia: ff6dbb006e4e60edba697639aa2a2a199b07069b
Gecko: afc933adf723
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140924061258
Gaia: 020e6283a033e8fbcf65e7ed81c5b75ba0095f22
Gecko: d6b762814638
Platform Version: 34.0a2
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0
Actual result: After turning off the Bluetooth headset, the song can be resumed with no audio or visual errors.

BuildID: 20140923195101
Gaia: 263e3b201dca967ec5346e35901aa981ca47dce7
Gecko: 35d791e16d31
Platform Version: 32.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
[Blocking Requested - why for this release]: Regression in a major feature (bluetooth) - bad UX
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth]

Comment 6

4 years ago
Triage: regression, blocking.
blocking-b2g: 2.1? → 2.1+
Duplicate of this bug: 1073491

Updated

4 years ago
Blocks: 1025317
Whiteboard: [CR 729246]

Updated

4 years ago
Whiteboard: [CR 729246] → [caf priority: p2][CR 729246]
B2g-inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.1
BuildID: 20140728005513
Gaia: 7306065260ceabd3138e4524e53670460c2c4e5f
Gecko: ac210add0225
Version: 34.0a1 (2.1)
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken
Environmental Variables:
Device: Flame 2.1
BuildID: 20140728013714
Gaia: 68a9fd19f05b503c945bef581870e4dc894cd1d3
Gecko: e1f382e14b7a
Version: 34.0a1 (2.1)
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 7306065260ceabd3138e4524e53670460c2c4e5f
Gecko: e1f382e14b7a

First Broken gaia / Last Working gekko - Issue does NOT occur
Gaia: 68a9fd19f05b503c945bef581870e4dc894cd1d3
Gecko: ac210add0225

Gecko Pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=ac210add0225&tochange=e1f382e14b7a
QA Whiteboard: [COM=Bluetooth] → [QAnalyst-Triage?][COM=Bluetooth]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(Reporter)

Comment 9

4 years ago
Adding blocker as the culprit is clear from the regression window in comment #8.
Blocks: 1037359
QA Whiteboard: [QAnalyst-Triage?][COM=Bluetooth] → [QAnalyst-Triage+][COM=Bluetooth]
Flags: needinfo?(jmitchell)
In my thinking, it could be same as bug 1072021. I'm checking it
After did some experiments, I found when problem is happening, ProcessDelayedA2dpRoute bt address is empty. This problem is the same as bug 1072021.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072021

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][COM=Bluetooth] → [QAnalyst-Triage+]

Updated

4 years ago
No longer blocks: 1025317
You need to log in before you can comment on or make changes to this bug.