full filesystem not handeled gracefully

VERIFIED DUPLICATE of bug 69938

Status

Core Graveyard
File Handling
--
major
VERIFIED DUPLICATE of bug 69938
17 years ago
2 years ago

People

(Reporter: * account discontinued *, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When trying to save a file via http or ftp Mozilla first saves the file to
a temporary location in /tmp.
When the filesystem on which /tmp resides is full, space made during the
download so the download can resume, the full file is downloaded, but not saved.
(the little progressbar fills up to 100%, but you don't get 100% of your file)
It appears that the file is only saved up to the point where the file in /tmp
was hitting a full filesystem and the rest of the data never gets written to the
file in /tmp

It would be most convenient if the file being saved is placed directly in the
place the user indicates it should be saved to prevent full /tmp problems
altogether.
Also, better errorhandling and possibly successful completion/resume of the 
download would be most convenient.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.