If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

naver.com isn't redirecting to mobile site on Firefox OS

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jongsoo.oh, Assigned: karlcow, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-ko] [serversniff] [sitewait], URL)

(Reporter)

Description

3 years ago
Site: http://www.naver.com
naver.com isn't redirecting to mobile site on Firefox OS

:: Steps To Reproduce
1.Open Firefox browser 
2.Enter naver.com

:: Expected Result
http://m.naver.com mobile site, it gets redirected for Android

:: Actual Result
http://www.naver.com desktop site
(Assignee)

Comment 1

3 years ago
Confirmed. 
The site needs to be contacted. We need to ask them to send Firefox OS the mobile version.
"User-Agent:  Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0"

Firefox Android and iOS Safari receives the mobile while the Firefox OS receives the desktop version.
This is server-side detection.




# Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: www.naver.com
User-Agent:  Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 200 OK
Cache-Control: no-cache, no-store, must-revalidate
Connection: close
Content-Encoding: gzip
Content-Type: text/html; charset=UTF-8
Date: Tue, 23 Sep 2014 05:32:17 GMT
P3P: CP="CAO DSP CURa ADMa TAIa PSAa OUR LAW STP PHY ONL UNI PUR FIN COM NAV INT DEM STA PRE"
Pragma: no-cache
Server: nginx
Transfer-Encoding: chunked
X-Frame-Options: SAMEORIGIN


# Firefox Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: www.naver.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 302 Moved Temporarily
Connection: keep-alive
Content-Type: text/html
Date: Tue, 23 Sep 2014 05:33:40 GMT
Location: http://m.naver.com
Server: nginx
Transfer-Encoding: chunked
Vary: Accept-Encoding,User-Agent



# iOS Safari

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: www.naver.com
User-Agent:  Mozilla/5.0 (iPhone; CPU iPhone OS 7_0 like Mac OS X) AppleWebKit/537.51.1 (KHTML, like Gecko) Version/6.0 Mobile/11A465 Safari/9537.53

HTTP/1.1 302 Moved Temporarily
Connection: close
Content-Type: text/html
Date: Tue, 23 Sep 2014 05:32:42 GMT
Location: http://m.naver.com
Server: nginx
Transfer-Encoding: chunked
Vary: Accept-Encoding,User-Agent
Whiteboard: [country-ko] [serversniff] [contactready]
(Assignee)

Updated

3 years ago
Mentor: kdubost@mozilla.com
(Assignee)

Comment 2

3 years ago
contacttwitter
Trying to contact a human 
http://twitter.com/MozWebCompat/status/514290871349428224
Assignee: nobody → kdubost
Whiteboard: [country-ko] [serversniff] [contactready] → [country-ko] [serversniff] [sitewait]
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
We got an answer:
> I forwarded the email from the person in charge. I will tweet you after I check it out.
(Assignee)

Comment 4

3 years ago
> @MozWebCompat The issue is fixed. thx.
http://twitter.com/mixed80/status/514651341025583104

Let's test. Working!
Thanks to Naver team.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.