Too many steps to open Home screen settings

RESOLVED DUPLICATE of bug 1007600

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1007600
4 years ago
4 years ago

People

(Reporter: Olof Wickström, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

Kill all running apps
In home screen long press an area in the background
Home-screen options menu is shown
Press "Homescreen Settings"


MUT HW: FLAME
MUT SW: Boot2Gecko2.2.0.0-prerelease Buildidentifier: 20140922160202


Actual results:

The settings-app is started. 
The start view of settings is shown
After a short while the slider buttons animate an change colour in the start view
After an additional short while the settings-app transitions to Homescreen view.


Expected results:

The settings app should have started in the Homescreen view directly
(Reporter)

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Updated

4 years ago
Component: General → Gaia::Homescreen

Comment 1

4 years ago
Kevin- can you let me know if this is a system issue or a bug with this particular transition to a page in the settings app?
Flags: needinfo?(kgrandon)
AFAIK - I think this is a settings issue. We need to support per-panel activities, and I'm not sure if we have the ability to do this yet.
Component: Gaia::Homescreen → Gaia::Settings
Flags: needinfo?(kgrandon)
We are tracking the issue with bug 1007600. This is planed to be land before FL of v2.2.
Depends on: 1007600

Comment 4

4 years ago
Removing the UX flag as this is being tracked in bug #1007600.
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

4 years ago
Blocks: 1076007
The issue is fixed along with bug 1007600.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007600
You need to log in before you can comment on or make changes to this bug.