Closed Bug 1071569 Opened 8 years ago Closed 8 years ago

Time-out in contacts camera

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

defect
Not set
normal

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED INVALID
2.1 S7 (24Oct)
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: olof.wickstrom, Assigned: hola)

Details

(Keywords: regression, Whiteboard: [p=9])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

Start Contacts app
Press plus to add a new contact
Press "+ Add picture"
Select Camera
Camera starts 
Press home button
Work with the phone for some time
Start Contacts app


Actual results:

Camera view finder opens. this give the impression you have started the camera instead of contacts


Expected results:

There should be a time-out in so the contacts app leave the camera view if it isn't active for some time.
MUT HW: FLAME
MUT SW: Boot2Gecko2.2.0.0-prerelease Buildidentifier: 20140922160202
Flags: needinfo?(firefoxos-ux-bugzilla)
This also affects 2.1. Moving the question to Carrie who designed the new Edit page in Contacts.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
Agree. This might cause a lot of confusion.
I'd suggest if users  leave the active camera page (either by tapping Home button or Task manager), we close the camera for them. So if they come back to the Contact APP, it will be the contact edit page. Thanks!
Flags: needinfo?(cawang)
That's actually a regression. In today's 2.0, we have the same issue but on 1.4 there is an animation that shows that the Camera panel is closed. See video for details: http://mzl.la/1psgb2q

Wilfred, do you think a partner would block on that bug with 2.0? If not, let's nominate this regression as a 2.1 blocker.
QA Whiteboard: [EditRedesign]
Flags: needinfo?(wmathanaraj)
Keywords: regression
Assignee: nobody → hola
(In reply to Johan Lorenzo [:jlorenzo] from comment #4)
> That's actually a regression. In today's 2.0, we have the same issue but on
> 1.4 there is an animation that shows that the Camera panel is closed. See
> video for details: http://mzl.la/1psgb2q
> 
> Wilfred, do you think a partner would block on that bug with 2.0? If not,
> let's nominate this regression as a 2.1 blocker.

I think we are talking about different issues here. Killing the app is not the same than kipping the app in the background and then coming back to it.

As I understand the first comment, the problem is when we are in the camara app via a web activity from contacts, come back to contacts app and we recover the contacts status, which is with the activity (so we see the camera app instead).
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #5)
You're right. Here's a video closer to the STR initially described: http://mzl.la/1sq3XPo
Target Milestone: --- → 2.1 S6 (10oct)
Whiteboard: [p=9]
Target Milestone: 2.1 S6 (10oct) → 2.1 S7 (24Oct)
I've been talking with other firefox os devs and they told me that this is a feature (closing open activties when the app calling them goes to background) that should be given by system. It is happening in other apps as well.

Any hints?
Flags: needinfo?(alive)
(In reply to Adrián de la Rosa from comment #7)
> I've been talking with other firefox os devs and they told me that this is a
> feature (closing open activties when the app calling them goes to
> background) that should be given by system. It is happening in other apps as
> well.
> 
> Any hints?

Yes, a general feature introduced in https://bugzilla.mozilla.org/show_bug.cgi?id=1028502
Flags: needinfo?(alive)
closing as per comment #8
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(wmathanaraj)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.