[v2.2] Investigate test_play_youtube_video failures

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RobertC, Assigned: martijn.martijn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
test_play_youtube_video has been failing intermittently on Jenkins in the past couple of weeks.
From the screenshot and staktrace it looks like the video does not resume playing we tapping of the player frame.

I was not able to reproduce the issue with manual or automated tests.

Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/2/workspace/flame-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_play_youtube_video.py", line 57, in test_play_youtube_video
self.assertTrue(player.is_video_playing())
AssertionError: False is not true

Build info v2.2 flame:
Gaia-Rev        3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/790f41c631cc
Build-ID        20140923040203
Version         35.0a1
Device-Name     flame
FW-Release      4.3
FW-Incremental  110
FW-Date         Fri Jun 27 15:57:58 CST 2014
Bootloader      L1TC00011230
Reporter

Comment 1

5 years ago
This test failed again on latest master at another step.
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/38/HTML_Report/

I was still not able to reproduce the issue manually or with automation.

Build info v2.2 flame:
Gaia-Rev        83de447d9ae9a59459d7a445f9348a254c661850
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/9ee9e193fc48
Build-ID        20141007040205
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141007.071347
FW-Date         Tue Oct  7 07:13:58 EDT 2014
Bootloader      L1TC10011800
Assignee

Updated

5 years ago
QA Whiteboard: fxosqa-auto-backlog+
Depends on: 1047168
Assignee

Updated

5 years ago
QA Whiteboard: fxosqa-auto-backlog+ → [fxosqa-auto-backlog+]
Assignee

Comment 2

5 years ago
Bug 1047168 will make it a local video test, that will very likely make this failure disappear.
QA Contact: martijn.martijn
Assignee

Updated

5 years ago
Assignee: nobody → martijn.martijn
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-s4]
Assignee

Comment 3

5 years ago
Fixed by bug 1047168.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.