make the global WebRTC sharing indicators actually list the streams with e10s enabled

VERIFIED FIXED in Firefox 35

Status

()

Firefox
Device Permissions
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

(Blocks: 2 bugs)

Trunk
Firefox 35
x86
All
Points:
5
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(e10sm6+)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 973001 fixed enough of the WebRTC UI with e10s enabled to have the permission prompts and the indicators showing, but clicking on the global or menubar indicators doesn't work: with e10s enabled, these indicators will show empty lists of streams.

This was split off from bug 973001 because it doesn't prevent WebRTC from being used.
Flags: qe-verify+
Flags: firefox-backlog+
tracking-e10s: --- → m6+
(Assignee)

Updated

4 years ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 8497549 [details] [diff] [review]
Patch v1
Attachment #8497549 - Flags: review?(felipc)
Attachment #8497549 - Flags: review?(felipc) → review+

Updated

4 years ago
Iteration: --- → 35.3

Updated

4 years ago
QA Contact: drno
https://hg.mozilla.org/mozilla-central/rev/7ee1bf648e8c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Reproduced the initial issue using old Nightly build (2014-09-30) across all platforms. Verified that using Nightly 35.0a1 before the patch (2014-10-02) and latest Nightly the issue is no longer reproducible.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Component: General → Device Permissions
You need to log in before you can comment on or make changes to this bug.