Closed Bug 1071702 Opened 7 years ago Closed 7 years ago

AsyncShutdown crash with "AddonManager: shutting down providers"

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1057312
Tracking Status
firefox32 --- unaffected
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected

People

(Reporter: kairo, Unassigned)

References

Details

(Keywords: crash, topcrash-win)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-5b578cd0-2b0b-4acc-bcf5-36f9b2140922.
=============================================================

Those crashes are AsyncShutdownTimeout with the following info:

{"phase": "profile-before-change",
 "conditions":
  [{"name": "AddonManager: shutting down providers",
    "state": "(none)",
    "filename":"resource://gre/modules/AddonManager.jsm",
    "lineNumber":744,
    "stack":
     ["resource://gre/modules/AddonManager.jsm:AMI_startup:744",
      "resource://gre/modules/AddonManager.jsm:AMP_startup:2322",
      "resource://gre/components/addonManager.js:AMC_observe:55",
      "null:null:0"]
   }]
}

[Tracking Requested - why for this release]:
I noticed today that all the crashes I was looking into out of the 6% of our AsyncShutdown crashes on 33.0b5 are this reason so this could help a lot if we can fix it still in beta.
Yoric: Do you still run AsyncShutdown analysis? I'd be very interested how much this bug really is of 33.0b5 and if we see it on other channels as well.

Looking at the code, I guess we actually are somewhere in the area of http://mxr.mozilla.org/mozilla-beta/source/toolkit/mozapps/extensions/AddonManager.jsm#745 and that means that bug 1012466, which landed in 33, is somewhat connected.

Georg, anything you can help here as you did that other patch?
Blocks: 1012466
Flags: needinfo?(georg.fritzsche)
Flags: needinfo?(dteller)
Digging through http://yoric.github.io/are-we-shutting-down-yet-/ tells me:
32 is not affected.
33: This is 94% of 1000 samples (~4091 total crashes over 5 days)
34 and 35 have little data there but see at least some of this.
Looks like a dupe of bug 1057312, right?
Flags: needinfo?(dteller)
(In reply to David Rajchenbach-Teller [:Yoric] (use "needinfo") from comment #3)
> Looks like a dupe of bug 1057312, right?

Yes. Not sure why I didn't find it. Probably one reason is because it's not marked as a crash with that signature.

Moving all the flags and stuff over there.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(georg.fritzsche)
Resolution: --- → DUPLICATE
Duplicate of bug: 1057312
You need to log in before you can comment on or make changes to this bug.