If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to stream few external RTSP streams

RESOLVED DUPLICATE of bug 1054171

Status

Firefox OS
RTSP
RESOLVED DUPLICATE of bug 1054171
3 years ago
3 years ago

People

(Reporter: bhargavg1, Assigned: ethan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caf priority: p2][CR 729193])

(Reporter)

Description

3 years ago
for the following RTSP public clips we fail to start streaming even though we can do on an Android/Linux (VLC) player 

rtsp://78.109.84.47/public/flux15
rtsp://78.109.84.47/public/flux14
rtsp://78.109.84.47/public/flux12
rtsp://78.109.84.47/public/flux11
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
(Reporter)

Updated

3 years ago
Whiteboard: [CR 729193]

Updated

3 years ago
Whiteboard: [CR 729193] → [caf priority: p2][CR 729193]

Updated

3 years ago
Blocks: 1025317
Adding qawanted to check if this is a regression in 2.1, given we had the RTSP support in 2.0 as well.
Keywords: qawanted
NI :bhargav to see if he can comment on #2.
Flags: needinfo?(bhargavg1)
I was unable to get the provided streams to work on 2.2 Flame Master. I was also unable to get the provided links to work on VLC player on Ubuntu.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140929125603
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: 6eb7121059fb
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: aalldredge
(Assignee)

Comment 5

3 years ago
VLC player and Android phone both can play the links specified in comment 0.
But Flame 2.2 cannot. I'll look into this issue.
Assignee: nobody → ettseng
(Assignee)

Comment 6

3 years ago
These RTSP links are live stream, a feature which Firefox OS doesn't support yet.

The range field in RTSP/SDP from the server reveals it's a live stream.
  Session Attribute (a): range:npt=now-
  Media Description, name and address (m): video 0 RTP/AVP 96
  Media Attribute (a): rtpmap:96 H264/90000
  ...

We have a plan to implement this feature in bug 1054171 ([RTSP] Support live stream over RTSP/RTP).
But we don't have a specific milestone (schedule) yet.
Howie, can you help to coordinate the requirement and schedule?
Flags: needinfo?(hochang)
(Reporter)

Updated

3 years ago
No longer blocks: 1025317
Flags: needinfo?(bhargavg1)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Comment 7

3 years ago
Thank you Ethan. Removing blocking nom and resolved duplicate to existing feature bug.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 3 years ago
Flags: needinfo?(hochang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1054171
You need to log in before you can comment on or make changes to this bug.