Status bar icons are screen reader accessible in the full screen apps like the Gallery.

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: yzen, Assigned: yzen, Mentored)

Tracking

({access})

unspecified
2.2 S7 (6mar)
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [b2ga11y p=1][good first bug][lang=css])

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
kgrandon
: review+
Details | Review
Assignee

Description

5 years ago
Screen reader user should not be able to swipe to the hidden status bar icons but currently can.
Steps to reproduce with screen reader:
* Open a Gallery app
* Swipe all the way right until the screen reader reaches the end.
* Expected: screen reader should stop on the last visible item on the screen.
* Observed: screen reader steps into the invisible status bar icons.

Comment 1

5 years ago
Can this bug be assigned to me please
Assignee

Comment 2

5 years ago
Hi Tanveer, sure, give it a try. Let me know if you have any additional questions!
Assignee: nobody → xzieodesigns
Assignee

Comment 3

5 years ago
Hi Tanveer, let me know if you have any questions about the bug. Thanks!
Flags: needinfo?(xzieodesigns)

Comment 4

5 years ago
(In reply to Yura Zenevich [:yzen] from comment #3)
> Hi Tanveer, let me know if you have any questions about the bug. Thanks!

Thank's Yura

Where can I access the code to make changes


In my module I've been told to go find a bug and then to fix i'm not sure where i can look at the code in order to fix  it
Flags: needinfo?(xzieodesigns)
Assignee

Comment 5

5 years ago
(In reply to Tanveer Ali from comment #4)
> (In reply to Yura Zenevich [:yzen] from comment #3)
> > Hi Tanveer, let me know if you have any questions about the bug. Thanks!
> 
> Thank's Yura
> 
> Where can I access the code to make changes
> 
> 
> In my module I've been told to go find a bug and then to fix i'm not sure
> where i can look at the code in order to fix  it

Yes, it's the statusbar icons are located here: https://github.com/yzen/gaia/blob/master/apps/system/index.html#L503-L538. There are 2 containers for them in the HTML: the ones with ids "statusbar-maximized" and "statusbar-minimized". You can find styling for these containers here: https://github.com/yzen/gaia/blob/master/apps/system/style/statusbar/statusbar.css. So what you would need to do is to add an additional condition in the existing CSS rules for the case that's described in the bug - the full screen and full screen layoyt apps.

Comment 6

5 years ago
My teacher has asked 

could you direct me to the relevent tools and development environment requirements to fix this bug

thanks

Comment 7

5 years ago
I'm pretty sure a simple html editor is suffice right..
Assignee

Comment 8

5 years ago
(In reply to Tanveer Ali from comment #7)
> I'm pretty sure a simple html editor is suffice right..

Correct, this should be a good one: http://www.sublimetext.com/

Comment 9

5 years ago
Hi yura,
Can you please tell me if i can produce this bug on desktop?

Comment 10

5 years ago
Hi yura,
I'm ready to do it if this bug can be reproduced and checked in desktop.
Assignee

Updated

4 years ago
Assignee: xzieodesigns → yzenevich
Status: NEW → ASSIGNED
Assignee

Updated

4 years ago
Attachment #8568113 - Flags: review?(alive)
Comment on attachment 8568113 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

Looks good, but I am asking Michael to double confirm.
Attachment #8568113 - Flags: review?(mhenretty)
Attachment #8568113 - Flags: review?(alive)
Attachment #8568113 - Flags: review+
Comment on attachment 8568113 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

Didn't see any visual difference with the statusbar behavior with this patch. Taking Yura's word for it this fixes accessibility, r=me
Attachment #8568113 - Flags: review?(mhenretty) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 15

4 years ago
Comment on attachment 8568113 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

[Approval Request Comment] This pull request makes status bar icons hidden from screen readers when they are not on screen in full screen apps.
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: If declined, the screen reader users will be able to step into status bar icons, even when they are not visible which is very confusing.
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8568113 - Flags: approval-gaia-v2.2?
Assignee

Comment 16

4 years ago
Comment on attachment 8568113 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

Removing for now.
Attachment #8568113 - Flags: approval-gaia-v2.2?
Assignee

Comment 17

4 years ago
This pull request caused a regression:
Steps to reproduce:
* Go into fullscreen app , such as video
* Turn the screen off
* Turn the screen on
Expected: statusbar icons visible
Observed: statusbar icons hidden.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Updated

4 years ago
Attachment #8568113 - Attachment is obsolete: true
Assignee

Comment 20

4 years ago
Comment on attachment 8569645 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

Statusbar icons should now be correctly visible when in lockscreen after screen off from a fullscreen app.
Attachment #8569645 - Flags: review?(kgrandon)
Comment on attachment 8569645 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

Left a comment on github, but this seems fine to me. Thanks!
Attachment #8569645 - Flags: review?(kgrandon) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Assignee

Comment 23

4 years ago
Comment on attachment 8569645 [details] [review]
[gaia] yzen:bug-1072092 > mozilla-b2g:master

[Approval Request Comment] This pull request makes status bar icons hidden from screen readers when they are not on screen in full screen apps.
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: If declined, the screen reader users will be able to step into status bar icons, even when they are not visible which is very confusing.
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8569645 - Flags: approval-gaia-v2.2?
Attachment #8569645 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 build.

Actual Results:  The status bar icons and search cannot be selected with the screen reader while in a full screen app.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

This issue is NOT fixed in the latest Nightly 2.2 build which does contain this commit.

Actual Results: The user can still select the search section of the status bar with the screen reader on full screen apps.

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
Flags: needinfo?(yzenevich)
Assignee

Comment 26

4 years ago
This is tracked in bug 1135805 which is about to re-land in master (and then, hopefully, in 2.2). This particular bug is for the status bar icons only.

Jayme, can we resolve this one?
Flags: needinfo?(yzenevich) → needinfo?(jmercado)
Yura: If the search bar is tracked in another issue then I can verify that this bug is fixed on 2.2 as well.
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage+]
Flags: needinfo?(yzenevich)
Flags: needinfo?(ktucker)
Flags: needinfo?(jmercado)
Assignee

Comment 28

4 years ago
Yes bug 1135805 is for the search bar.
Flags: needinfo?(yzenevich)
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.