Uncaught promise rejection from gmpInstallManager.simpleCheckAndInstall()

RESOLVED FIXED in Firefox 35

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

unspecified
Firefox 35
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8494265 [details] [diff] [review]
patch

We may not care about doing anything with the promise rejection but simpleCheckAndInstall already logs a sane error message, we don't need the log spew caused by the uncaught promise rejection, particularly since this can cause test failures in some harnesses.
Attachment #8494265 - Flags: review?(netzen)
(Assignee)

Updated

4 years ago
Assignee: nobody → dtownsend+bugmail
Status: NEW → ASSIGNED
Comment on attachment 8494265 [details] [diff] [review]
patch

Review of attachment 8494265 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, I wasn't aware that we logged unfulfilled promise rejections.
Attachment #8494265 - Flags: review?(netzen) → review+
https://hg.mozilla.org/mozilla-central/rev/8bc7b34bd8ec
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
You need to log in before you can comment on or make changes to this bug.