MobileConnectionService doesn't have to be created in 'profile-after-change' category

RESOLVED FIXED in 2.1 S7 (24Oct)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: vicamo, Assigned: edgar)

Tracking

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox35 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1064231 +++
(Reporter)

Updated

4 years ago
Assignee: nobody → vyang

Updated

4 years ago
Duplicate of this bug: 1074982
This causes a console error in Fennec on startup (Bug 1074982), because we don't have these lines in our package manifest.

http://mxr.mozilla.org/mozilla-central/source/b2g/installer/package-manifest.in#166
Status: NEW → ASSIGNED
status-firefox35: --- → affected
(Assignee)

Comment 3

4 years ago
Created attachment 8505893 [details] [diff] [review]
Patch, v1
(Assignee)

Comment 4

4 years ago
Comment on attachment 8505893 [details] [diff] [review]
Patch, v1

MobileConnectionService doesn't have to be created in 'profile-after-change' category. It could be created by calling getService() when some one needs to access it.

Olli, may I have your review? Thank you.
Attachment #8505893 - Flags: review?(bugs)
Comment on attachment 8505893 [details] [diff] [review]
Patch, v1

Uh uh, do_CreateInstance(GONK_MOBILECONNECTION_SERVICE_CONTRACTID); was interesting bug.
Attachment #8505893 - Flags: review?(bugs) → review+
(Assignee)

Updated

4 years ago
Assignee: vicamo → echen
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.1 S7 (24Oct)
https://hg.mozilla.org/mozilla-central/rev/0bd52a74a872
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.