Closed Bug 1072539 Opened 5 years ago Closed 5 years ago

Only ForceDiscard in imgFrame::GetFrame if it's safe to do so

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: seth, Assigned: seth)

References

Details

Attachments

(1 file)

I suspect bug 1069369's root cause is that we don't check whether it's safe to ForceDiscard() in imgFrame::GetFrame() before doing so. Let's add that check. This is a speculative fix, but I think there's good reason to believe that it will work, since the crash seems to be caused by a null value for RasterImage::mDecodeRequest, which is cleared by ForceDiscard().
Here's the patch.
Attachment #8494742 - Flags: review?(tnikkel)
Here's a try job. If anyone can use the Android build to verify that this fixes bug 1069369 for them (i.e., they can consistently reproduce without this patch, but not with it) I'd appreciate it. I still can't reproduce bug 1069369 reliably.

https://tbpl.mozilla.org/?tree=Try&rev=1473dd4056fc
Comment on attachment 8494742 [details] [diff] [review]
Only ForceDiscard() in imgFrame::GetFrame() if it's safe to do so

Yeah, this felt a little unsafe when reviewing the original patch.
Attachment #8494742 - Flags: review?(tnikkel) → review+
Thanks for the quick review!

Try looks good, so I went ahead and pushed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/5aa68330b3f0
https://hg.mozilla.org/mozilla-central/rev/5aa68330b3f0
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.