Support OMTA for preserve-3d transforms

RESOLVED DUPLICATE of bug 779598

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 779598
3 years ago
2 years ago

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

Tracking

29 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
We currently disable OMTA for preserve-3d, it would be nice if we could stop doing that.

The computed transform on the nsDisplayTransform includes the transforms from all the preserve-3d ancestors. We'd need to split these back up and ship them to the compositor separately with their individual animation functions.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779598
You need to log in before you can comment on or make changes to this bug.