Closed Bug 1072600 Opened 5 years ago Closed 5 years ago

Can't paste text when using span with contendeditable attribute

Categories

(Core :: Editor, defect)

32 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 858918

People

(Reporter: vorcak.jan, Unassigned)

References

Details

(Whiteboard: DUPEME)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

1) Create following HTML:
<span contenteditable>Try to paste some text in here</span>
2) Try to paste some content in this element. (Sometimes I needed to modify this element first to break this)

http://jsfiddle.net/q16trpwb/


Actual results:

I can't paste any content when using <span> tag.


Expected results:

It works OK with Opera, Chrome and also with Firefox when using <p> or <div>
Sometimes it looks like it works, but to reproduce it in 100% cases do following:

1) Select all text with Ctrl+a
2) Cut with Ctrl+x 
3) Try to paste
Component: General → Editor
Version: unspecified → 32 Branch
Surely already reported, here the dupe for FF for Android (bug 783846).
Whiteboard: DUPEME
See Also: → 569932
See Also: → 858918
See Also: → 583980
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
This might be fixed with bug 858918.  Could you try in the current or next nightly?  (I don't know if it's in the current nightly yet.)
I tested, it's fixed in the daily Nightly.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858918
See Also: 858918
You need to log in before you can comment on or make changes to this bug.