Closed Bug 1072623 Opened 5 years ago Closed 4 years ago

jscntxt.cpp:990:16: warning: enumeration value ‘WITH’ not handled in switch [-Wswitch]

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dholbert, Unassigned)

References

(Blocks 2 open bugs)

Details

New build warning, with GCC (ver 4.8)
{
js/src/jscntxt.cpp:990:16: warning: enumeration value ‘WITH’ not handled in switch [-Wswitch]
          switch (ssi.type()) {
                 ^
}

This is in code added by bug 947044.
Link to switch statement:
 http://hg.mozilla.org/mozilla-central/rev/1049cfbf3426#l8.156

fitzgen, can you extend this 'switch' to have a clause for this missing enum value? (Perhaps an empty clause, if that's appropriate; I don't know.)
Flags: needinfo?(nfitzgerald)
Yeah, empty clause.
Duplicate of this bug: 1073087
I backed out bug 947044.
Flags: needinfo?(nfitzgerald)
I am closing this bug because fitzgen backed out the code that introduced this warning (bug 947044).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.