[The Weather Channel] The zip code entry screen display after user entered a zip code

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: psiphantong, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8494811 [details]
wz.txt

Description:
After entering a zip code, the zip code entry screen keeps displaying when the user opens the weather channel app

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20140924000243
2) Install the weather channel from the Marketplace
3) Open the weather channel > enter zip code to complete initial location set
4) Force close app
5) Launch app


Actual:
zip code entry screen display

Expected:
No zip code entry screen


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140924000243
Gaia: 93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b
Gecko: d7e31ecd48af
Version: 34.0a2 (2.1)
Firmware: Unknown
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8494814 [details]
2014-09-24-16-42-01.png
(Reporter)

Comment 2

4 years ago
This issue also reproduce on the Flame 2.2 KitKat Base (319mb), Flame 2.1 KitKat Base (512mb), and the Flame 2.0 KitKat Base (319mb). The zip code entry screen display


Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140924013003
Gaia: ff6dbb006e4e60edba697639aa2a2a199b07069b
Gecko: 1e2993c99323
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140924000243
Gaia: 93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b
Gecko: d7e31ecd48af
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924003005
Gaia: 263e3b201dca967ec5346e35901aa981ca47dce7
Gecko: 35d791e16d31
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
not nominating this as a blocker as this is a tech evangelism issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 4

3 years ago
I was unable to reproduce this issue as you described it.  For me, when I entered (then saved) my location, closed the app, and reopened, my saved location showed as the first screen.  

Pete -  After entering your location, are you prompted to save as a favorite?  if so did you follow this step as well?
Blocks: 977321

Comment 5

3 years ago
Pete no longer seems to have a bugzilla account, we will monitor this issue for reproducibility. TWC is currently reworking their mobile website for major improvements.  Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.