(QFA)Talkback error: Can't initialize.

RESOLVED FIXED

Status

SeaMonkey
Installer
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Jim Avera, Assigned: Syd Logan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This happens every time with Build ID 2001102806 on Linux:

% mozilla
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/plugins
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
(QFA)Talkback error: Can't initialize.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Otherwise mozilla seems to work ok.

Comment 1

17 years ago
I don't see any problem. Please try today's build and re-open this if it still
happens.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Build 2001102910 for Linux does not issue *any* messages about Talkback
upon startup (either that it started or that it didn't).

Is there some other way to tell if Talkback was started?

Or, maybe Talkback didn't even attempt to start because of bug 107547
(an XML error message which always appears at startup with this
build, something about mailNavigatorOverlay.xul...)

Comment 3

17 years ago
I installed mozilla build 2001-10-29-09 (which has a master.ini of 2001102910) I
couldn't find a build with the date mentioned.  I forced a crash in the 10-29-09
build and was able to submit a talkback report(37420089)without any trouble. 
Where did you get the build you installed, Jim?  
(Reporter)

Comment 4

17 years ago
I just downloaded
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu-installer.tar.gz
and ran it to install mozilla, and got Build ID 2001102910.
md5sum: 941b3849db9a45b1b5111a97582abcca  mozilla-bin

I didn't say Talkback was not starting, only that there is no
longer any message on stdout/stderr mentioning Talkback.
Sorry for any confusion.

Here's my terminal window output:

> mozilla
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/plugins
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
XML Error in file 'chrome://messenger/content/mailNavigatorOverlay.xul', Line
Number: 41, Col Number: 55, Description: not well-formed
Source Line:       var shouldShowSendPage = !gContextMenu.onImage &&
!gContextMenu.onLink && !gContextMenu.onTextInput;
(that's all)
(Reporter)

Comment 5

17 years ago
Re-opening because the problem re-appeared in Linux build 2001103108 :

  (QFA)Talkback error: Can't initialize.

appears when mozilla is started. 

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

17 years ago
Talkback does not initialize for me either. #2001102608

$ /usr/local/mozilla/mozilla
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/plugins
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
(QFA)Talkback error: Can't initialize.

Comment 7

17 years ago
Reporters: which flavor of Linux are you using?
(Reporter)

Comment 8

17 years ago
I'm running SuSE 7.2 for Intel, kernel 2.4.7-SMP, libc.so.6
(Reporter)

Comment 9

17 years ago
The error message is gone now in Linux build 2001110612.
(Reporter)

Comment 10

17 years ago
The problem is back once again in Linux build 2001111314:
(QFA)Talkback error: Can't initialize.

*** NEW INFO *** 
     The problem only happens when running as a regular user,
     but not when running as root (at least no such error
     message appears when starting mozilla as root).

I installed mozilla using the nightly build installer, 
running as root (some bug in the install process 
prevents installing as an ordinary user).

? Does talkback need to write into the mozilla install directory
  (which is not world-writable)?
(Reporter)

Comment 11

17 years ago
The Talkback init error goes away if $HOME/.fullcircle is removed!

I will attach a tar archive of the .fullcircle.

Verifiers, would you please move aside your own .fullcircle
and install this one to see if you can see the same problem?
Thanks.
(Reporter)

Comment 12

17 years ago
Created attachment 57830 [details]
tar archive of .fullcircle/ which causes the Talkback init error

Comment 13

17 years ago
I removed ~/.fullcircle and started mozilla, and I still get:

(QFA)Talkback error: Can't initialize.

I'm running Slackware Linux 8.0.0 - Mozilla build 2001111408

Comment 14

17 years ago
Okay, I fixed it. Had to make sure talkback was moved back into components/

Thanks.
Jim Avera do you still see this problem on recent nightlies?
(Reporter)

Comment 16

17 years ago
Ah. The problem is that the mozilla-installer process creates a file 
under $HOME named

  $HOME/.fullcircle/NetscapeMozillaTrunkLinuxIntel<buildid>/permdata.box

mozilla-installer was run as root via the sudo command, which leaves environment
variables like HOME unchanged.  Therefore this file was created
in the ordinary user's home dir but owned by root, and so could not be removed
or modified by a mozilla process run by the ordinary user.

Talkback starts okay if the permdata.box file is removed or ownership
changed back to the ordinary user in whose home directory it exists.
And, of course, if mozilla-installer is run without sudo.

---

mozilla-installer should not reference $HOME or any user-specific data,
because the user who installs mozilla is not in general the user
who will run it (or run talkback).  Multiple users may run mozilla,
so anything which the installer needs to save should be saved in the
product install directory, not in the installing user's private files.

So, talkback should get the build-id or whatever it needs
from the product installation directory.
->Installer
Assignee: namachi → syd
Status: UNCONFIRMED → NEW
Component: Talkback → Installer
Ever confirmed: true
QA Contact: chofmann → bugzilla

Comment 18

17 years ago
I'm only QA on Windows...
QA Contact: bugzilla → ktrina

Comment 19

17 years ago
Confirming comment 16. Had this problem for several months up to and including
build 2002-01-11-08-trunk (Linux), but after running chown -R <me> in my
${HOME}/.fullcircle directory, which was owned by root, it all seems fine -
mozilla was installed with sudo.

Updated

15 years ago
Depends on: 57089

Comment 20

14 years ago
bug 57089 is fixed.  this should no longer be a problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.