[v2.2] Capture crash report for intermittent crash in cost control tests

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
test_cost_control_ftu crashed in the latest Jenkins run when trying to launch cost control app.

I was not able to reproduce the issue locally with manual or automated testing. Ran the automated test 20 times.

Device info flame v2.2:
Device firmware (date) 	25 Sep 2014 04:30:34
Device firmware (incremental) 	eng.cltbld.20140925.073024
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	25 Sep 2014 00:29:46
Gaia revision 	c5d2e2f4ebf5
Gecko build 	20140925040206
Gecko revision 	32acbe1d64dc
Gecko version 	35.0a1

Jenkins stacktrace:
Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_ftu.py", line 14, in test_cost_control_ftu
cost_control.launch()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 27, in launch
self.app = self.apps.launch(self.name, self.manifest_url, self.entry_point, launch_timeout=launch_timeout)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 65, in launch
result = self.marionette.execute_async_script("GaiaApps.launchWithName('%s')" % name, script_timeout=launch_timeout)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 1252, in execute_async_script
filename=os.path.basename(frame[0]))
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/decorators.py", line 35, in _
return func(*args, **kwargs)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 638, in _send_message
self._handle_error(response)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 700, in _handle_error
raise errors.ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
ScriptTimeoutException: ScriptTimeoutException: timed out

I attached a part of the logcat with the test run on Jenkins in case it helps.
Test test_cost_control_reset_wifi.py has failed in today's build with the same error: 
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.non-smoke/15/HTML_Report/
The phone crashed during Cost Control app launch. 
I couldn't reproduce the crash locally, by running the automated test several times.

Device firmware (date) 	30 Sep 2014 04:12:09
Device firmware (incremental) 	eng.cltbld.20140930.071158
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	29 Sep 2014 08:46:19
Gaia revision 	77ef35f5429b
Gecko build 	20140930040206
Gecko revision 	7c24470b6b3a
Gecko version 	35.0a1
Summary: [v2.2] Capture crash report for intermittent crash in test_cost_control_ftu → [v2.2] Capture crash report for intermittent crash in cost control tests
Assignee

Updated

5 years ago
Assignee: nobody → robert.chira
Assignee

Comment 2

5 years ago
I was unable to reproduce this issue locally.
I also started an adhoc which passed 71 out of 71.
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/210/HTML_Report/

If the issue reoccurs reopen the bug.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [fxosqa-auto-s1]
You need to log in before you can comment on or make changes to this bug.