New notification indicator stays on even if you cleared all notifications

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: rik, Assigned: albertopq)

Tracking

({regression})

unspecified
2.1 S6 (10oct)
regression
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Make sure you have no notifications in the notification tray
2. Receive a call and don't answer it
3. Open the phone app
4. Go to call log

Expected:
The blue new notification indicator should be gone

Actual:
Notification indicator is still there.

Note:
If you open the notification tray after that, you can see that there are no notifications in the notification tray.
I'd say the new notification tray is only in v2.2. Right Michael?
blocking-b2g: --- → 2.2?
Flags: needinfo?(mhenretty)
This probably has something to do with the way the attention screen adds notifications. We shouldn't show the ambient notification indicator for the attention screen, so that is the bug.


(In reply to Julien Wajsberg [:julienw] from comment #1)
> I'd say the new notification tray is only in v2.2. Right Michael?

The ambient indicator is in 2.1, but I don't think the attention window made it in for that. In any case, QA wanted for branch checks on 2.1 and 2.2 only.
blocking-b2g: 2.2? → 2.1?
Flags: needinfo?(mhenretty)
Keywords: qawanted
(In reply to Michael Henretty [:mhenretty] from comment #2)
> In any case, QA wanted for branch checks on 2.1 and 2.2 only.

This issue is reproducible on Flame 2.2. After accessing Call Log at step 4, the blue notification bar on top of screen remains until user pulls down the utility tray (and see there is 0 notification).

Device: Flame
BuildID: 20140925134737
Gaia: a06714c555ca7068545f10b4437a16c14cd8e7f5
Gecko: 9e3d649b80a2
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

----------

This issue is NOT reproducible on Flame 2.1. After accessing Call Log at step 4, the blue notification bar on top of screen disappears.

Device: Flame
BuildID: 20140925140043
Gaia: 86905e14c3ff06a0e6952ba635b6066ad2eea6b4
Gecko: bc8aad860662
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/35.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Alberto, can you take a look here?
blocking-b2g: 2.1? → ---
Flags: needinfo?(apastor)
(Assignee)

Comment 5

3 years ago
Sure thing.
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 6

3 years ago
Created attachment 8495789 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24464
Attachment #8495789 - Flags: review?(mhenretty)
[Blocking Requested - why for this release]:
Blocks a blocker.
blocking-b2g: --- → 2.1?
Attachment #8495789 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 8

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/eba7fb64e20b175d3ac3181c9bf4ec0ec01a51e7
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED

Updated

3 years ago
Whiteboard: [systemsfe]
see comment 7
blocking-b2g: 2.1? → 2.1+
We need an approval anyway, Alberto.
Flags: needinfo?(apastor)
(Assignee)

Comment 11

3 years ago
2.1 is still not affected, until Bug 1065519 lands. That's the reason I was waiting for requesting approval. Should I request approval anyways? Thanks Julien!
Flags: needinfo?(apastor)
Yeah, please do, both will be uplifted in the same time :)
(Assignee)

Comment 13

3 years ago
Comment on attachment 8495789 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24464

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1065519 
[User impact] if declined: Notifications not cleared correctly
[Testing completed]: Added unit tests for the affected use cases
[Risk to taking this patch] (and alternatives if risky): Simple fix. Low risk
[String changes made]:-
Attachment #8495789 - Flags: approval-gaia-v2.1?(fabrice)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: unaffected → affected
Attachment #8495789 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/b0fe1073010b0589d884c28673072b5493f3bc49
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.1 S6 (10oct)
This issue is verified on Flame 2.2:

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141001040205
Gaia: 0e280591881d44b80f456bc27e12d9114c218868
Gecko: 14665b1de5ee
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The blue new notification indicator disappears after accessing call long
===============================================
This issue still reproduces on Today's Flame 2.1(Nithglty):

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

2.1 was uplifted yesterday. Leaving veryfime keyword to verify tomorrow.
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue is verified on Flame 2.1 as well:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141003000203
Gaia: 9861c61ec302fb0316c753a2e1c0f592180515fd
Gecko: da68900d1c66
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The blue new notification indicator disappears after accessing call long
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: verifyme
(Assignee)

Comment 17

3 years ago
Created attachment 8506058 [details] [review]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25215
Attachment #8506058 - Flags: review?(etienne)
Comment on attachment 8506058 [details] [review]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25215

lots of small comments so worth an extra review round but this is a very welcome clean-up :)
Attachment #8506058 - Flags: review?(etienne) → feedback+
(Assignee)

Comment 19

3 years ago
Comment on attachment 8506058 [details] [review]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25215

Totally agree with the comments. Just sent an update :)
Thanks for the review!
Attachment #8506058 - Flags: review?(etienne)
Comment on attachment 8506058 [details] [review]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25215

r=me with the last comments addressed... and a green try build (had issues locally with the last test)
Attachment #8506058 - Flags: review?(etienne) → review+
(Assignee)

Comment 21

3 years ago
It seems that the last test is failing as you mentioned, but I cannot repro it locally. Could you please send me the log? Thanks!
Flags: needinfo?(etienne)
(In reply to Alberto Pastor [:albertopq] from comment #21)
> It seems that the last test is failing as you mentioned, but I cannot repro
> it locally. Could you please send me the log? Thanks!

Well, this drove me a little crazy, especially since it works with VERBOSE=1.
I think it's a race, but it might be a gecko race.

The best and safest fix I have is to add this in the setup()
```
  var sys = new System(client);
  sys.waitForStartup();
```

(with the correct require)

We'll watch out for intermittent but looks like this completely fixes the issue.
Flags: needinfo?(etienne)
Alberto, how are we doing here? Did Etienne's suggestion fix the tests?
Flags: needinfo?(apastor)
(Assignee)

Comment 24

3 years ago
TESTS master: https://github.com/mozilla-b2g/gaia/commit/b2f6a1aced1e3a81f90af4b48f4b417a5d5b08e9

Finally... green!
Flags: needinfo?(apastor) → in-testsuite+
You need to log in before you can comment on or make changes to this bug.