External app URL bar button shows when in lockscreen guest mode

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: wesj)

Tracking

({uiwanted})

Trunk
All
Android
uiwanted
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(Reporter)

Description

4 years ago
* Add the lockscreen widget to the screen
* launch Firefox from the lockscreen
* visit maps.google.com
* android icon is shown in the address bar

* clicking the android icon kicks you out of the browser and back to the lockscreen and launches Google Maps but you can't get to it until you unlock the phone

We need to have UX define a behavior here, either don't show the helper icon or request unlocking of the phone.

Updated

4 years ago
Blocks: 815682
(Assignee)

Comment 1

4 years ago
We should probably also show something on mailto links (or any schemes we don't support). Right now I think they'll just launch behind the keyguard, so you'll see them when you finally unlock your phone.
Probably not showing the app icon is counter to user expectations -- need some kind of affordance to know why the behavior is different.

I have a hunch that there are already patterns defined around this, and prompting to unlock is likely involved, but... UX team, ASSEMBLE!

*insert ascii art of Japanese robot TV shows here*
Keywords: uiwanted
Summary: launch external app button show when in lockscreen guest mode → External app URL bar button shows when in lockscreen guest mode
Just doing a quick drive by here, but I think we could just not show the app icon since that action kinda goes outside the scope of "guest browsing" here. 

Having the indicator in the Status bar will also help set some expectations. But also, we must remember that these aren't our everyday users anymore, they've arrived at this from the Lock Screen, I'm not sure we need to give them any more context nor do they have the same expectation.
It has always been a bit odd to use a lockscreen widget and then forget you started the process and have to enter your code when trying to complete another task, but it's not terrible UX either. Especially when you're using a lockscreen widget to complete a task that you already have an app for. The helper icon should still show, because that's a defined pattern. If the idea behind the widget is weighing on "Guest Browsing" then perhaps we could use some messaging that reminds the user of that in case they stumble upon this use case again.

Comment 5

4 years ago
wesj, are we backing this feature out of 35? Just setting tracking to 35 for now to make sure this is addressed.
Assignee: nobody → wjohnston
tracking-fennec: ? → 35+
(Assignee)

Comment 6

4 years ago
Turned off on Aurora.
tracking-fennec: 35+ → ---

Comment 7

4 years ago
(In reply to Wesley Johnston (:wesj) from comment #6)
> Turned off on Aurora.

Is there a plan for where we'll ship this? 36?
tracking-fennec: --- → ?
This turns out to be our intended behavior
Status: NEW → RESOLVED
tracking-fennec: ? → -
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.