Closed Bug 1073400 Opened 8 years ago Closed 8 years ago

[Contacts] [ICE] When all ICE Contacts are unset the ICE Contact group list is displayed as empty

Categories

(Firefox OS Graveyard :: Gaia::Contacts, enhancement)

ARM
Gonk (Firefox OS)
enhancement
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jmcf, Assigned: jmcf)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

Set ICE contact 1. Then go Contacts List. Open the ICE Group. One contact is displayed. Edit such a Contact and remove all tel numbers. Pop-up appears. dismiss it. then you will return to the ICE Contacts group that will be showed as empty. See capture. 

Expected: If there are no longer ICE Contacts the contacts list should be displayed directly and that last step ommited (as the ICE Group no longer exists)
Attached image 2014-09-26-09-45-54.png
Assignee: nobody → jmcf
Target Milestone: --- → 2.1 S5 (26sep)
Attached file 24465.html
We need to continue working with integration tests. but please could you have a look at this WIP?

thanks!
Attachment #8495795 - Flags: feedback?(crdlc)
Comment on attachment 8495795 [details]
24465.html

LGTM, it is a good solution
Attachment #8495795 - Flags: feedback?(crdlc) → feedback+
Attachment #8495795 - Flags: review?(crdlc)
Comment on attachment 8495795 [details]
24465.html

Perfect! I left a comment in github. It works fine. Good job. Thanks
Attachment #8495795 - Flags: review?(crdlc) → review+
[Blocking Requested - why for this release]: This is an major issue for a new feature, that prevents the user from setting ICE contacts again.
blocking-b2g: --- → 2.1?
QA Whiteboard: [ICE]
https://github.com/mozilla-b2g/gaia/commit/16923c235095fac1f89513157d4d9084bf3f78ed
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
How many times have we solve this bug? xD
triage: regression
blocking-b2g: 2.1? → 2.1+
Please nominate this patch for Gaia v2.1 approval when you get a chance :)
Flags: needinfo?(jmcf)
Comment on attachment 8495795 [details]
24465.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New feature ICE Contacts
[User impact] if declined: High. Navigation is ost. The app shows inconsistent information
[Testing completed]: Yes, including integration tests
[Risk to taking this patch] (and alternatives if risky): Low risk patch 
[String changes made]:
Attachment #8495795 - Flags: approval-gaia-v2.1?
Flags: needinfo?(jmcf)
Attachment #8495795 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
this issue is verified fixed in flame 2.2 and flame 2.1 

After turing on the ICE contact and leaving it blank there is not a contact group named ICE that is empty, now if there is no ICE contact entered the ICE contact group will not appear. This was confirmed on both of the ICE contact spots.

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [ICE] → [ICE] [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [ICE] [QAnalyst-Triage?] → [ICE] [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.