[Lockscreen] Actionable notification destination for missed call shows blank blue screen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: amylee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-VH-bug-bash])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8495981 [details]
2014-09-26-10-40-21.png

Steps to reproduce:

1. Call the flame device to activate "missed call" actionable notification on lockscreen. 

2. Open missed call notification from lockscreen. 

3. It takes you to a blank blue screen.
(Reporter)

Updated

4 years ago
Assignee: nobody → jlu
Greg, could you take a look at this? Thanks.
Assignee: jlu → nobody
Flags: needinfo?(gweng)
This is a dialer app bug.
Component: Gaia::System::Lockscreen → Gaia::Dialer
Flags: needinfo?(gweng)
Whiteboard: [2.0-VH-bug-bash][systemsfe] → [2.0-VH-bug-bash]
I can't reproduce this on a Flame. It correctly opens the Dialer on the Call log tab.

What is 2.0-VH ?
Flags: needinfo?(amlee)
(Reporter)

Comment 4

4 years ago
(In reply to Anthony Ricaud (:rik) from comment #3)
> I can't reproduce this on a Flame. It correctly opens the Dialer on the Call
> log tab.
> 
> What is 2.0-VH ?

Hi Anthony, 

I just flashed my device to the latest (Oct 1) engineer master build. It seems now that missed calls don't even appear on lockscreen.

I would ask Tim about the "2.0-VH".
Flags: needinfo?(amlee)
(In reply to Anthony Ricaud (:rik) from comment #3) 
> What is 2.0-VH ?
If you mean "2.0-VH" in "[2.0-VH-bug-bash]", it was a bug bash performed only for the Vertical Homescreen on 2.0. We did that at the time to secure this core 2.0 functionality.
Amy: I doubt that we have this error because it is tested by our daily smoketests. So it seems to be on your device only. Have you updated both Gaia and Gecko ?
Flags: needinfo?(amlee)
(Reporter)

Comment 7

4 years ago
(In reply to Anthony Ricaud (:rik) from comment #6)
> Amy: I doubt that we have this error because it is tested by our daily
> smoketests. So it seems to be on your device only. Have you updated both
> Gaia and Gecko ?

I've updated gaia/gecko and also flashed my phone to the newest base image. I've tested it out on other flame devices and don't have this issue. For whatever reason it only happens on my flame device. But if this isn't a wide issue than this bug can be closed. Thanks!
Flags: needinfo?(amlee)
Let's close it then. If it reproduces on more devices, we can always reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.