Non-ascii characters shown incorrectly in email "From"-field

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Message Display
RESOLVED WONTFIX
3 years ago
11 months ago

People

(Reporter: Peter Madsen, Unassigned)

Tracking

({regression})

SeaMonkey 2.29 Branch
seamonkey2.46
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29.1
Build ID: 20140923221838

Steps to reproduce:

Open the Mail & Newsgroups window and open a mail from any person that has any of the letters æ, ø or å (and pobably any non-asci character) in his/her name.


Actual results:

In the from field (in the maiil itself) æ, ø and å is shown as � - and the wrong characters are referred like this if I right click the From field and choose "Compose Mail To", ot to the quote header if I click the Reply button.


Expected results:

æ, ø and å should be shown correctly as they for example are in the From column.

If I look into the Message Source I can see that the From field in the mail header of the affected mails are in plain ansi.  In other mails where the From field is prefixed with =?ISO-8859-1?q? and encoded, there is no such problem with the non-ansi characters.  You could say that the from field is malformed by the mailing agent, but Seamonkey has always before been able to show these ansi characters correctly according to the current Windows codepage - and Seamonkey stil shows them correct in the from COLUMN in the mail list.

Comment 1

3 years ago
@reporter:
Please send such an e-mail to me.
Component: General → MailNews: Message Display
Flags: needinfo?(petermad)

Comment 2

3 years ago
Created attachment 8611002 [details]
screenshot comparison

REPRODUCIBLE with reporter's sample document and EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Default Theme) on German WIN7 64bit:

a) opening file in SeaMonkey will show show characters different form
   "ø æ å Æ Ø Å " in "from" line
b) looks ok in Thunderbird 31.6.0

Comment 3

3 years ago
Created attachment 8611004 [details]
reporter's sample document

Simply save on HDD and open file from SM Mail Menu 'File -> Open' for your test

Comment 4

3 years ago
c) No DUPs found in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=1073713DUPs&list_id=12280816>
d) In a strange way this problem seems to be limited tro "from" field?
1. Open attached.eml with Thunderbird
2. Menu 'Mail → Answer'
   » New mail created
3. Add you e-mail-address to "To" and send email to yourself
4. Open this mail in SeaMonkey:
   » Now in "To" the Name characters separated by blanks look as they should.
OS: Windows XP → Windows
Summary: Non-ascii characters shown incorrectly in email From field → Non-ascii characters shown incorrectly in email "From"-field

Comment 5

3 years ago
Strange!
a) I tried with an account where I added ä ö ü Ä ö Ü Ẁ to my name string and sent 
   a test mail to 2 of my accounts: worked fine, problem not visible.
   But in the little message coming up at right end of WIN Task Bar I see 
   a rhombus with question mark in it instead of all ä, ö, ...

b) I subscribed a feed for <http://planet.mozilla.de/>. In the news mails I get
   all postings of Sören Hentzschel show the problem, I see a rhombus with
   question mark in it instead of "ö"
   And in the little message coming up at right end of WIN Task Bar I see 
   a rhombus with question mark in it instead of all ä, ö, ...

c) Ah, I see, reporter already told the reason: "... prefixed with
   =?ISO-8859-1?q? "
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(petermad)

Updated

3 years ago
See Also: → bug 1169601

Comment 6

3 years ago
Regression due to user story
Keywords: regression

Comment 7

3 years ago
Was still ok  with EN-US SeaMonkey 2.26  (Portable) Gecko/20100101 Firefox/29.0 Build 20140428215944 (Default Theme) on German WIN7 64bit

Comment 8

3 years ago
Still REPRODUCIBLE with EN-US SeaMonkey 2.38a1 build by Ruediger Lahl, Gecko/20100101, Build 20150531140409 (Default Theme) on German WIN7 64bit

So this one seems not to be a DUP of bug 1169601, what already has been fixed for this Version.

Comment 9

3 years ago
Here <https://seamonkeyde.wordpress.com/2015/05/29/bestatigung-bug-1073713-nicht-ascii-zeichen-werden-nicht-korrekt-dargestellt/#comments> I read in Peter Bätz' comment, that the problem also is visible with  Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
OS: Windows → All

Comment 10

3 years ago
We probably need something like Bug 1170002 but for the message window.

Comment 11

3 years ago
Same problem here with:

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 SeaMonkey/2.33.1
Comment hidden (spam)
Comment hidden (offtopic)
tracking-b2g: backlog → ---
Flags: needinfo?(nagym3824)
(Reporter)

Comment 14

a year ago
This issue seems to be fixed in SeaMonkey 2.46 :-)

Comment 15

a year ago
At least your email you sent to me 26.05.2015 now looks fine in 2.46

Comment 16

a year ago
NOT / no longer reproducible with official  German SeaMonkey 2.46 RC (Build 9)  (Windows NT 6.1; WOW64; rv:49.0)  Gecko/20100101 Firefox/49.0 Build 20161213183751  (Default Classic Theme)  on German WIN7 64bit.

But still reproducible with 2.40 and same user profile.

so WFM 2.46 for now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Target Milestone: --- → seamonkey2.46
(Reporter)

Comment 17

11 months ago
I was a bit too hasty in my report from 2016-12-24.  The problem is fixed when Viewing an email with non-ascii charaters in the "From" field, but if I open such an email to Reply to it, then the non-ascii characters in the line: "John Doe wrote" is still showing wrongly as for example: "
Tina M�ller wrote:" in stead of: "Tina Møller wrote".
You need to log in before you can comment on or make changes to this bug.