Relative link status is lost after an image or link is moved in the page

NEW
Unassigned

Status

defect
5 years ago
4 years ago

People

(Reporter: sv1grb, Unassigned)

Tracking

SeaMonkey 2.10 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29.1
Build ID: 20140923221838

Steps to reproduce:

Created some links and thumbnails with photos links. Saved the page.
At the image location properties and at the link properties the "URL is relative to page location" is checked

Then when formatting the page, I moved some links and photos (or paste from another page of the same site). All the links had the "URL is relative to page" checked.


Actual results:

The URL relative status is lost at all the moved or pasted links and photos.


Expected results:

The URL relative status should be the same as before the links or photos was moved or pasted.

Comment 1

4 years ago
@reporter:
Please send a zip with some folders, html document(s)  and pictures from sub folders in html document so that we can try to reproduce
Flags: needinfo?(sv1grb)
(Reporter)

Comment 2

4 years ago
Flags: needinfo?(sv1grb)
(Reporter)

Comment 3

4 years ago
This also happens in later version 2.33.1 that I am using now


Thanks

Comment 4

4 years ago
REPRODUCIBLE with reporter's test kit and EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Default Theme) on German WIN7 64bit:

1. Unzip test kit in arbitrary "FOLDER" on HDD
   » Sub folder with some files will be created
2. in Commposer from file menu open "varoper.htm"
   » In yellow area all pictures shown
3. Save as "varoper001.htm"
4. Save as "varoper002.htm"
5. Drag and drop left picture in second pictures row in yellow area up to 
   pictures row 1  
6. Drag and drop right picture in second pictures row in yellow area up to 
   pictures row 1 
7. Save and close 
8. Rename "FOLDER" to "FOLDER_X_"
9. In Browser open "varoper001.htm"
   » looks ok
10. In Browser open "varoper002.htm"
   Bug: moved pictures (and may be others) replaced by placeholders.
   Checking picture link locations shows that picture URL still shows  "FOLDER"
   instead of  "FOLDER_X_"
11. in Composer open open "varoper002.htm"
    » left and right picture in first picture row in yellow area also
      only show placeholder, after double click on placeholders you will
      see that "URL relative" checkmark now is missing  

a) no DUPs found in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=1073797DUPs&list_id=12280896>
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

4 years ago
Version: SeaMonkey 2.29 Branch → SeaMonkey 2.33 Branch

Comment 5

4 years ago
<https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines#General_Outline_of_a_Bug_Report<
* Version: select the earlyest Version with what the problem can be reproduced

@Reporter:
Please do not modify selector contents without a comment
Version: SeaMonkey 2.33 Branch → SeaMonkey 2.29 Branch

Comment 6

4 years ago
With steps due to comment 3 already reproducible with SeaMonkey 2.10
Version: SeaMonkey 2.29 Branch → SeaMonkey 2.10 Branch
You need to log in before you can comment on or make changes to this bug.