XMLHttpRequest.prototype.responseURL should not have fragment per latest spec

RESOLVED FIXED in mozilla35

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: xKhorasan, Assigned: xKhorasan)

Tracking

(Blocks 1 bug, {dev-doc-needed})

Trunk
mozilla35
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140927030204

See: https://github.com/whatwg/xhr/commit/9fd9bb483001231f55f380a319b00ca32bdb5222
XHR spec changed to serialize response's URL without fragment.  Since Firefox currently return responseURL with fragment, its behavior should be fixed.

Steps to reproduce:
1. Launch Firefox and open http://request-xkhorasan.rhcloud.com/responseURL/fragment

Actual result:
responseURL for http://request-xkhorasan.rhcloud.com/test#fragment: http://request-xkhorasan.rhcloud.com/test#fragment

Expected result:
responseURL for http://request-xkhorasan.rhcloud.com/test#fragment: http://request-xkhorasan.rhcloud.com/test
(Assignee)

Comment 1

5 years ago
Posted patch patch v1Splinter Review
Attachment #8496490 - Flags: review?(bugs)
Attachment #8496490 - Flags: review?(bugs) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → xKhorasan+mozilla
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/aefb2886f165
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35

Updated

4 years ago
Depends on: 1117873
You need to log in before you can comment on or make changes to this bug.